ramips: add support for GL.iNet VIXMINI
authorDavid Bauer <mail@david-bauer.net>
Fri, 12 Apr 2019 22:05:47 +0000 (00:05 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Sat, 13 Apr 2019 16:46:40 +0000 (18:46 +0200)
Hardware
--------
SoC:   MediaTek MT7628NN
RAM:   64M DDR2 (Etron EM68B16CWQD-25H)
FLASH: 8M (Winbond W25Q64JVSIQ)
LED:   Power - WLAN
BTN:   Reset
UART:  115200 8N1
       TX and RX are labled on the board as pads next to the SoC

Installation via web-interface
------------------------------
1. Visit the web-interface at 192.168.8.1
   Note: The ethernet port is by default WAN. So you need to connect to
   the router via WiFi

2. Navigate to the Update tab on the left side.

3. Select "Local Update"

4. Upload the OpenWrt sysupgrade image.
   Note: Make sure you select not to preserve the configuration.

Installation via U-Boot
-----------------------
1. Hold down the reset button while powering on the device.
   Wait for the LED to flash 5 times.

2. Assign yourself a static IPv4 in 192.168.1.0/24

3. Upload the OpenWrt sysupgrade image at 192.168.1.1.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/dts/VIXMINI.dts [new file with mode: 0644]
target/linux/ramips/image/mt76x8.mk

index 5fcf437fbd23f0e93a56181fa9d88f374fba67ce..89cdf57b3e34dd9909e727456330648abf14203f 100755 (executable)
@@ -367,6 +367,7 @@ ramips_setup_interfaces()
                        "0:lan:4" "1:lan:3" "2:lan:2" "3:lan:1" "5:wan" "6@eth0"
                ;;
        dlink,dir-510l|\
+       glinet,vixmini|\
        netgear,ex6150|\
        re350-v1)
                ucidef_add_switch "switch0" \
diff --git a/target/linux/ramips/dts/VIXMINI.dts b/target/linux/ramips/dts/VIXMINI.dts
new file mode 100644 (file)
index 0000000..5a52fe2
--- /dev/null
@@ -0,0 +1,114 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "mt7628an.dtsi"
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+/{
+       compatible = "glinet,vixmini", "mediatek,mt7628an-soc";
+       model = "GL.iNet VIXMINI";
+
+       aliases {
+               led-boot = &led_power;
+               led-failsafe = &led_power;
+               led-running = &led_power;
+               led-upgrade = &led_power;
+       };
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       memory@0 {
+               device_type = "memory";
+               reg = <0x0 0x4000000>;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_power: power {
+                       label = "vixmini:blue:power";
+                       default-state = "on";
+                       gpios = <&gpio1 10 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan {
+                       label = "vixmini:white:wlan";
+                       gpios = <&gpio1 12 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 6 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "wdt", "wled_an", "p1led_an";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&ethernet {
+       mtd-mac-address = <&factory 0x4>;
+};
+
+&wmac {
+       status = "okay";
+
+       ralink,mtd-eeprom = <&factory 0x0>;
+};
+
+&spi0 {
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       partition@0 {
+                               label = "u-boot";
+                               reg = <0x0 0x30000>;
+                               read-only;
+                       };
+
+                       partition@30000 {
+                               label = "u-boot-env";
+                               reg = <0x30000 0x10000>;
+                               read-only;
+                       };
+
+                       factory: partition@40000 {
+                               label = "factory";
+                               reg = <0x40000 0x10000>;
+                               read-only;
+                       };
+
+                       partition@50000 {
+                               compatible = "denx,uimage";
+                               label = "firmware";
+                               reg = <0x50000 0x7b0000>;
+                       };
+               };
+       };
+};
index cb8f1819556798bad102cce98106d8cceede100f..02b03e5007c4f511f3584fbffc0e48fac3f4727c 100644 (file)
@@ -66,6 +66,14 @@ define Device/gl-mt300n-v2
 endef
 TARGET_DEVICES += gl-mt300n-v2
 
+define Device/glinet_vixmini
+  DTS := VIXMINI
+  IMAGE_SIZE := 7872k
+  DEVICE_TITLE := GL.iNet VIXMINI
+  SUPPORTED_DEVICES += vixmini
+endef
+TARGET_DEVICES += glinet_vixmini
+
 define Device/hc5661a
   DTS := HC5661A
   IMAGE_SIZE := $(ralink_default_fw_size_16M)