fix quilt integration
authorTim Yardley <lst@openwrt.org>
Tue, 2 Oct 2007 21:54:22 +0000 (21:54 +0000)
committerTim Yardley <lst@openwrt.org>
Tue, 2 Oct 2007 21:54:22 +0000 (21:54 +0000)
SVN-Revision: 9100

include/quilt.mk

index 6ae615792fe093c50f1f5290c48cb385ea2c3950..667653f320b30f6d096dbbf739d00243510850b5 100644 (file)
@@ -132,7 +132,7 @@ define Build/Quilt
                echo "The source directory contains no quilt patches."; \
                false; \
        }
                echo "The source directory contains no quilt patches."; \
                false; \
        }
-       @[ -n "$$$$(ls $(PKG_BUILD_DIR)/patches/*/series)" -o "$$$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
+       @[ -n "$$$$(ls $(PKG_BUILD_DIR)/patches/series)" -o "$$$$(cat $(PKG_BUILD_DIR)/patches/series | md5sum)" = "$$(sort $(PKG_BUILD_DIR)/patches/series | md5sum)" ] || { \
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }
                echo "The patches are not sorted in the right order. Please fix."; \
                false; \
        }