change mtd partition map, use rootfs_split, and generate a firmware image for the...
authorGabor Juhos <juhosg@openwrt.org>
Mon, 13 Oct 2008 17:28:47 +0000 (17:28 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Mon, 13 Oct 2008 17:28:47 +0000 (17:28 +0000)
SVN-Revision: 12976

target/linux/storm/config-default
target/linux/storm/image/Makefile
target/linux/storm/patches/007-mtd.patch

index 2ff7f47b39bae7a077a89bd8ba5b3b0ef98a3c4d..7b44e84d38e8056e375cdd7b260e235c1b07404f 100644 (file)
@@ -138,7 +138,6 @@ CONFIG_HW_RANDOM=y
 # CONFIG_INET_ESP is not set
 # CONFIG_INET_IPCOMP is not set
 # CONFIG_INET_TUNNEL is not set
-CONFIG_INET_XFRM_MODE_BEET=m
 # CONFIG_INET_XFRM_MODE_TRANSPORT is not set
 # CONFIG_INET_XFRM_MODE_TUNNEL is not set
 # CONFIG_INET_XFRM_TUNNEL is not set
@@ -211,8 +210,6 @@ CONFIG_MTD_REDBOOT_DIRECTORY_BLOCK=-1
 CONFIG_MTD_REDBOOT_PARTS=y
 # CONFIG_MTD_REDBOOT_PARTS_READONLY is not set
 # CONFIG_MTD_ROM is not set
-# CONFIG_MTD_ROOTFS_ROOT_DEV is not set
-# CONFIG_MTD_ROOTFS_SPLIT is not set
 # CONFIG_MTD_SERIAL is not set
 CONFIG_MTD_SL2312_CFI=y
 # CONFIG_MTD_SL2312_SERIAL_ATMEL is not set
@@ -250,6 +247,7 @@ CONFIG_NET_SL351X=y
 # CONFIG_NEW_LEDS is not set
 # CONFIG_NFSD is not set
 # CONFIG_NFS_FS is not set
+CONFIG_NF_CONNTRACK=y
 # CONFIG_NLS is not set
 # CONFIG_NO_IDLE_HZ is not set
 # CONFIG_NO_IOPORT is not set
@@ -263,7 +261,6 @@ CONFIG_PCI=y
 CONFIG_PCI_SYSCALL=y
 # CONFIG_PPP_MPPE is not set
 # CONFIG_PPP_SYNC_TTY is not set
-CONFIG_PRINTK_TIME=y
 # CONFIG_PROVE_LOCKING is not set
 # CONFIG_RCU_TORTURE_TEST is not set
 CONFIG_RTC_LIB=y
index b061c6d0efc479d529e1afaca190faf745cc4fc9..e94c463ec5a353e8e5e428131c7b94331eade80a 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -19,23 +19,28 @@ define Image/BuildKernel
 #      BIN_DIR=$(BIN_DIR) $(TOPDIR)/scripts/arm-magic.sh
 endef
 
-define Image/Build
-       $(call Image/Build/$(1),$(1))
-endef
-
 define Image/Build/jffs2-64k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=65536 conv=sync
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=64k conv=sync
 endef
 
 define Image/Build/jffs2-128k
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-       $(call Image/Build/slug,$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=128k conv=sync
 endef
 
 define Image/Build/squashfs
-    $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
-       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-$(1).img bs=131072 conv=sync
-       $(call Image/Build/slug,$(1))
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
+define Image/Build
+       $(call Image/Build/$(1),$(1))
+       dd if=$(KDIR)/root.$(1) of=$(BIN_DIR)/openwrt-$(BOARD)-root.$(1) bs=128k conv=sync
+
+       -$(STAGING_DIR_HOST)/bin/mkfwimage2 \
+               -m GEOS -f 0x30000000 -z \
+               -v WILI-S.WILIBOARD.v5.00.SL3512.OpenWrt.00000.000000.000000 \
+               -o $(BIN_DIR)/openwrt-$(BOARD)-wbd-111-$(1).bin \
+               -p Kernel:0x020000:0x100000:0:0:$(BIN_DIR)/openwrt-$(BOARD)-zImage \
+               -p Ramdisk:0x120000:0x500000:0:0:$(BIN_DIR)/openwrt-$(BOARD)-root.$(1)
 endef
 
 $(eval $(call BuildImage))
index 8e397bc620beafb288d08e95651fc79aeedfc5ae..d6c6d568134f9a39194bfdd33797c1a9d2aadf0d 100644 (file)
 +
 --- /dev/null
 +++ b/drivers/mtd/maps/sl2312_flashmap.h
-@@ -0,0 +1,21 @@
+@@ -0,0 +1,20 @@
 +/*
 + * Please note that the name are used in mkflash script. Therefore
 + * don't change them.  If you want to add different partitions, you
 +static struct mtd_partition sl2312_partitions[] = {
 +      { name: "RedBoot",       offset: 0x00000000, size: 0x00020000, },
 +      { name: "kernel",        offset: 0x00020000, size: 0x00100000, },
-+      { name: "rootfs",        offset: 0x00120000, size: 0x00500000, },
-+      { name: "rootfs_data",   offset: 0x00620000, size: 0x001A0000, },
++      { name: "rootfs",        offset: 0x00120000, size: 0x006A0000, },
 +      { name: "VCTL",          offset: 0x007C0000, size: 0x00010000, },
 +      { name: "cfg",           offset: 0x007D0000, size: 0x00020000, },
 +      { name: "FIS directory", offset: 0x007F0000, size: 0x00010000, }