add sata_sil24 module Signed-off-by: Erik Inge Bols? <knan-openwrt@anduin.net>
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 15:42:16 +0000 (15:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 19 Apr 2009 15:42:16 +0000 (15:42 +0000)
SVN-Revision: 15261

package/kernel/modules/block.mk

index 3c2781397297e18a7fd56f9c307742d4bfb066d7..ce9596e8a8e26356b783f878a7790c32a42e1319 100644 (file)
@@ -35,6 +35,22 @@ endef
 $(eval $(call KernelPackage,ata-ahci))
 
 
+define KernelPackage/ata-sil24
+  SUBMENU:=3D$(BLOCK_MENU)
+  TITLE:=3DSilicon Image 3124/3132 SATA support
+  DEPENDS:=3Dkmod-ata-core
+  KCONFIG:=3DCONFIG_SATA_SIL24
+  FILES:=3D$(LINUX_DIR)/drivers/ata/sata_sil24.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=3D$(call AutoLoad,41,sata_sil24)
+endef
+
+define KernelPackage/ata-sil24/description
+ Support for Silicon Image 3124/3132 Serial ATA controllers.
+endef
+
+$(eval $(call KernelPackage,ata-sil24))
+
+
 define KernelPackage/ata-artop
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=ARTOP 6210/6260 PATA support