kernel: bump 4.19 to 4.19.67
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Fri, 16 Aug 2019 11:26:23 +0000 (13:26 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 27 Aug 2019 08:32:44 +0000 (10:32 +0200)
Refreshed all patches.

Also add a missing symbol for x86 which got used now in this bump.
- ISCSI_IBFT

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/hack-4.19/902-debloat_proc.patch
target/linux/generic/pending-4.19/613-netfilter_optional_tcp_window_check.patch
target/linux/x86/64/config-4.19
target/linux/x86/generic/config-4.19
target/linux/x86/geode/config-4.19
target/linux/x86/legacy/config-4.19

index 354b493236ad4df6c6b2c14135d4e0196ff5a401..87bf09f00d3d52fedaea23a276166e7d57c2300c 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .189
 LINUX_VERSION-4.14 = .139
-LINUX_VERSION-4.19 = .66
+LINUX_VERSION-4.19 = .67
 
 LINUX_KERNEL_HASH-4.9.189 = 93d945661246f726b694455c80c140717d2beff5a718445a51183439bbe5d0b3
 LINUX_KERNEL_HASH-4.14.139 = 8c62d495444dba90200740ec770d274780b010e957cfc447f07999d717e37042
-LINUX_KERNEL_HASH-4.19.66 = c981abe15c4b9496cdadb04e4f4afb88b3a78f31ced8d07684ee9c58b3fadb64
+LINUX_KERNEL_HASH-4.19.67 = 5a1c3d60c38a7a0a086fcd6fdce5603c31c487852b1b64c071ee6de62c98a502
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index a396ad0d12f11d5367a01770a5a1b252aaca003a..e70f030cb8a2ec9094074ea8049909e133fc9c80 100644 (file)
@@ -232,7 +232,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!pe)
 --- a/mm/vmalloc.c
 +++ b/mm/vmalloc.c
-@@ -2740,6 +2740,8 @@ static const struct seq_operations vmall
+@@ -2749,6 +2749,8 @@ static const struct seq_operations vmall
  
  static int __init proc_vmalloc_init(void)
  {
index 2bc48f87cf723c83fa7ca2c8257be1173d49e422..634218dfc318bf2fb4c0907e1b6f639d0684a9b2 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  /* "Be conservative in what you do,
      be liberal in what you accept from others."
      If it's non-zero, we mark only out of window RST segments as INVALID. */
-@@ -483,6 +486,9 @@ static bool tcp_in_window(const struct n
+@@ -484,6 +487,9 @@ static bool tcp_in_window(const struct n
        s32 receiver_offset;
        bool res, in_recv_win;
  
@@ -28,7 +28,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        /*
         * Get the required data from the packet.
         */
-@@ -1057,7 +1063,7 @@ static int tcp_packet(struct nf_conn *ct
+@@ -1059,7 +1065,7 @@ static int tcp_packet(struct nf_conn *ct
                 IP_CT_TCP_FLAG_DATA_UNACKNOWLEDGED &&
                 timeouts[new_state] > timeouts[TCP_CONNTRACK_UNACK])
                timeout = timeouts[TCP_CONNTRACK_UNACK];
@@ -37,7 +37,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
                 timeouts[new_state] > timeouts[TCP_CONNTRACK_RETRANS])
                timeout = timeouts[TCP_CONNTRACK_RETRANS];
        else
-@@ -1506,6 +1512,13 @@ static struct ctl_table tcp_sysctl_table
+@@ -1508,6 +1514,13 @@ static struct ctl_table tcp_sysctl_table
                .mode           = 0644,
                .proc_handler   = proc_dointvec,
        },
index 43642e5a66077b7bc252480bc0b2ca09a8a899fb..ddbd818dfcc48d41a177e98ee96d04e00b08292d 100644 (file)
@@ -292,6 +292,7 @@ CONFIG_INTEL_SOC_DTS_THERMAL=y
 CONFIG_IOMMU_HELPER=y
 CONFIG_IOSF_MBI=y
 # CONFIG_IOSF_MBI_DEBUG is not set
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_KALLSYMS_ABSOLUTE_PERCPU=y
 # CONFIG_KVM_DEBUG_FS is not set
index e769835b73a54257e318b1a8aecc96a19b574213..4a689ca026c72242ecf38e6a6cd59756bcc44786 100644 (file)
@@ -231,6 +231,7 @@ CONFIG_IRQ_BYPASS_MANAGER=y
 CONFIG_ISA=y
 CONFIG_ISAPNP=y
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_ISO9660_FS=y
 # CONFIG_JOLIET is not set
index 9ee50f89f5ed21e92b8733436df413911449e3c5..5b01ecf00a603d5cb1a69848923d40bd932c971b 100644 (file)
@@ -68,6 +68,7 @@ CONFIG_IOSF_MBI=y
 CONFIG_ISA=y
 # CONFIG_ISAPNP is not set
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 # CONFIG_LANCE is not set
 CONFIG_LEDS_GPIO=y
index 4fcbc05aef290a59b5a4ae41dd2cf6a258fff283..2e5199185af252578854d360dd6435837430e03f 100644 (file)
@@ -143,6 +143,7 @@ CONFIG_IOSF_MBI=y
 CONFIG_ISA=y
 CONFIG_ISAPNP=y
 CONFIG_ISA_BUS_API=y
+# CONFIG_ISCSI_IBFT is not set
 # CONFIG_ISCSI_IBFT_FIND is not set
 CONFIG_ISO9660_FS=y
 # CONFIG_JOLIET is not set