ipv6-support: Fix typo in dhcpv6-script * thanks to KarlHegbloom for reporting
authorSteven Barth <cyrus@openwrt.org>
Mon, 31 Dec 2012 09:38:59 +0000 (09:38 +0000)
committerSteven Barth <cyrus@openwrt.org>
Mon, 31 Dec 2012 09:38:59 +0000 (09:38 +0000)
SVN-Revision: 34940

package/network/ipv6/ipv6-support/Makefile
package/network/ipv6/ipv6-support/files/dhcpv6.sh

index 43ebb1f35d42f99cdb22d4069712aa9bea1bcc06..7e2e5e91dc506c9718c8657e69dcd05a1e303f20 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=ipv6-support
-PKG_VERSION:=2012-12-30
+PKG_VERSION:=2012-12-31
 PKG_RELEASE:=1
 
 include $(INCLUDE_DIR)/package.mk
index 25355bedf2b135e281c2254dd04af5ec34cbffd9..299cf99f3d1322c632cf247e5c50742f92259a17 100755 (executable)
@@ -30,7 +30,7 @@ setup_prefix_fallback "$fallback" "$network" "$device"
 
 
 # Operations in case of success
-[ "$state" == "timeout" || "$state" == "unbound" ] && exit 0
+[ "$state" == "timeout" -o "$state" == "unbound" ] && exit 0
 
 local peerdns
 config_get_bool peerdns "$network" peerdns 1