toolchain: when using musl, install a symlink from ld-musl-*.so to /usr/bin/ldd
authorFelix Fietkau <nbd@openwrt.org>
Sun, 19 Oct 2014 21:45:58 +0000 (21:45 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 19 Oct 2014 21:45:58 +0000 (21:45 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42974

package/libs/toolchain/Makefile

index 72ce6b90e184b0d85e0a3692e16b9dbf77e20e4a..1de0c2807a43553aac91977e2e0a9af169c70d0c 100644 (file)
@@ -468,13 +468,14 @@ ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   LD_MUSL_NAME = $(notdir $(firstword $(wildcard $(TOOLCHAIN_DIR)/lib/ld-musl-*.so*)))
 
   define Package/musl/install
-       $(INSTALL_DIR) $(1)/lib
+       $(INSTALL_DIR) $(1)/lib $(1)/usr/bin
        $(CP) \
                $(TOOLCHAIN_DIR)/lib/ld-musl-*.so* \
                $(1)/lib/
        $(CP) \
                $(TOOLCHAIN_DIR)/lib/libc.so* \
                $(1)/lib/
+       ln -s ../../lib/$(LD_MUSL_NAME) $(1)/usr/bin/ldd
        $(if $(findstring -sf.so,$(LD_MUSL_NAME)),ln -s $(LD_MUSL_NAME) $(1)/lib/$(subst -sf.so,.so,$(LD_MUSL_NAME)))
   endef