package/kernel: add module for the Pericom PT7C4338 RTC chip
authorGabor Juhos <juhosg@openwrt.org>
Sun, 29 Apr 2012 15:08:23 +0000 (15:08 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 29 Apr 2012 15:08:23 +0000 (15:08 +0000)
Signed-off-by: Wojciech Dubowik <Wojciech.Dubowik@neratec.com>
SVN-Revision: 31526

package/kernel/modules/other.mk

index d6eab58704896a3d7df5235f30c463616dde3f44..0a467f92fda3b52b39c5f80ff6ebfca9135ed1d4 100644 (file)
@@ -828,6 +828,20 @@ endef
 
 $(eval $(call KernelPackage,rtc-pcf2123))
 
+define KernelPackage/rtc-pt7c4338
+  SUBMENU:=$(OTHER_MENU)
+  TITLE:=Pericom PT7C4338 RTC support
+  $(call AddDepends/rtc,+kmod-i2c-core)
+  KCONFIG:=CONFIG_RTC_DRV_PT7C4338
+  FILES:=$(LINUX_DIR)/drivers/rtc/rtc-pt7c4338.ko
+  AUTOLOAD:=$(call AutoLoad,60,rtc-pt7c4338)
+endef
+
+define KernelPackage/rtc-pt7c4338/description
+ Kernel module for Pericom PT7C4338 i2c RTC chip.
+endef
+
+$(eval $(call KernelPackage,rtc-pt7c4338))
 
 define KernelPackage/n810bm
   SUBMENU:=$(OTHER_MENU)