sunxi: create KDIR_TMP, build boot.img in it
authorZoltan Herpai <wigyori@uid0.hu>
Sat, 15 Aug 2015 14:56:21 +0000 (14:56 +0000)
committerZoltan Herpai <wigyori@uid0.hu>
Sat, 15 Aug 2015 14:56:21 +0000 (14:56 +0000)
It's nice to have a distinction between files which are built during the
normal OpenWrt build process and ones that are created by the ImageBuilder
(like it already exists on some other targets).

This also gives boot.img a profile-specific prefix as it contains profile-
specific data.

KDIR_TMP does not need to be specified since include/image.mk already sets
it.

Signed-off-by: Matthias Schiffer <mschiffer@universe-factory.net>
Signed-off-by: Zoltan HERPAI <wigyori@uid0.hu>
SVN-Revision: 46607

target/linux/sunxi/image/Makefile

index 19ab935f3b80f942b5b2f9a69f66d85cc8c67497..10d2200aa3ce510322151a9e8280e1c05fa107b7 100644 (file)
@@ -12,6 +12,8 @@ FAT32_BLOCK_SIZE=1024
 FAT32_BLOCKS=$(shell echo $$(($(CONFIG_SUNXI_SD_BOOT_PARTSIZE)*1024*1024/$(FAT32_BLOCK_SIZE))))
 
 define Image/BuildKernel
+       -mkdir -p $(KDIR_TMP)
+
        mkimage -A arm -O linux -T kernel -C none \
                -a 0x40008000 -e 0x40008000 \
                -n 'ARM OpenWrt Linux-$(LINUX_VERSION)' \
@@ -29,16 +31,16 @@ define Image/BuildKernel
 endef
 
 define Image/Build/SDCard
-       rm -f $(KDIR)/boot.img
-       mkdosfs $(KDIR)/boot.img -C $(FAT32_BLOCKS)
+       rm -f $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img
+       mkdosfs $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img -C $(FAT32_BLOCKS)
 
-       mcopy -i $(KDIR)/boot.img $(KDIR)/uboot-sunxi-$(PROFILE)-boot.scr ::boot.scr
-       mcopy -i $(KDIR)/boot.img $(DTS_DIR)/$(2).dtb ::dtb
-       mcopy -i $(KDIR)/boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
+       mcopy -i $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img $(KDIR)/uboot-sunxi-$(PROFILE)-boot.scr ::boot.scr
+       mcopy -i $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img $(DTS_DIR)/$(2).dtb ::dtb
+       mcopy -i $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img $(BIN_DIR)/$(IMG_PREFIX)-uImage ::uImage
 
        ./gen_sunxi_sdcard_img.sh \
                $(BIN_DIR)/$(IMG_PREFIX)-$(PROFILE)-sdcard-vfat-$(1).img \
-               $(KDIR)/boot.img \
+               $(KDIR_TMP)/$(IMG_PREFIX)-$(PROFILE)-boot.img \
                $(KDIR)/root.$(1) \
                $(CONFIG_SUNXI_SD_BOOT_PARTSIZE) \
                $(CONFIG_TARGET_ROOTFS_PARTSIZE) \