Revert "include/image.mk: call Image/Build/{cpiogz,targz}"
authorFlorian Fainelli <florian@openwrt.org>
Tue, 4 Dec 2012 22:59:05 +0000 (22:59 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 4 Dec 2012 22:59:05 +0000 (22:59 +0000)
This breaks on platforms building their own targz/cpioz images.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34498

include/image.mk

index 7758c9a90a35c21821acaac7771b653c1d667c0b..503115ddb093b073bdd3f1209b282ae5f982c1c8 100644 (file)
@@ -109,7 +109,6 @@ endif
 ifneq ($(CONFIG_TARGET_ROOTFS_CPIOGZ),)
   define Image/mkfs/cpiogz
                ( cd $(TARGET_DIR); find . | cpio -o -H newc | gzip -9 >$(BIN_DIR)/$(IMG_PREFIX)-rootfs.cpio.gz )
-               $(call Image/Build,cpiogz)
   endef
 endif
 
@@ -117,7 +116,6 @@ ifneq ($(CONFIG_TARGET_ROOTFS_TARGZ),)
   define Image/mkfs/targz
                # Preserve permissions (-p) when building as non-root user
                $(TAR) -czpf $(BIN_DIR)/$(IMG_PREFIX)-rootfs.tar.gz --numeric-owner --owner=0 --group=0 -C $(TARGET_DIR)/ .
-               $(call Image/Build,targz)
   endef
 endif