kernel: bump 4.19 to 4.19.56
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 25 Jun 2019 10:56:13 +0000 (12:56 +0200)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 25 Jun 2019 14:46:01 +0000 (16:46 +0200)
Refreshed all patches.

Compile-tested on: cns3xxx
Runtime-tested on: cns3xxx

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/apm821xx/patches-4.19/802-usb-xhci-force-msi-renesas-xhci.patch
target/linux/bcm53xx/patches-4.19/180-usb-xhci-add-support-for-performing-fake-doorbell.patch
target/linux/generic/hack-4.19/940-cleanup-offload-hooks-on-netdev-unregister.patch
target/linux/generic/pending-4.19/201-extra_optimization.patch

index 599d6ef3fd71dd88eca03089900a5b6113a30b5a..288d9a90dcc536e241b41642625f63955b5e4c1e 100644 (file)
@@ -8,11 +8,11 @@ endif
 
 LINUX_VERSION-4.9 = .183
 LINUX_VERSION-4.14 = .130
-LINUX_VERSION-4.19 = .55
+LINUX_VERSION-4.19 = .56
 
 LINUX_KERNEL_HASH-4.9.183 = fd57b0991cdbf4e2e933c260356a4768d6685a77460684f8de36a59fd42867f3
 LINUX_KERNEL_HASH-4.14.130 = 29ca9050ff9a60b7ab3b23d4b7da008df8b0f7329492a7bc84c1685481745259
-LINUX_KERNEL_HASH-4.19.55 = c906f0cba7998c5942aaf7034ef8ea925f04f47a673816da05b203e97360b947
+LINUX_KERNEL_HASH-4.19.56 = 7326943215b9496f302e95892457a63d9a77e0446e99dd7bade6b425bc966bdf
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index 238da6190d5da8e67f243efcf811b5c5d64b997d..a745ea6f44a263aa8e5ca806b49521319856af6c 100644 (file)
@@ -43,7 +43,7 @@ produce a noisy warning.
                hcd->msi_enabled = 1;
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1867,6 +1867,7 @@ struct xhci_hcd {
+@@ -1876,6 +1876,7 @@ struct xhci_hcd {
        /* support xHCI 0.96 spec USB2 software LPM */
        unsigned                sw_lpm_support:1;
        /* support xHCI 1.0 spec USB2 hardware LPM */
index 68ae5d4162a18787a6c3d61b1aa817434a1209b9..6bd46a2bcd5294256ec0ac38c05f881f6859bc73 100644 (file)
@@ -127,7 +127,7 @@ it on BCM4708 family.
  /*
 --- a/drivers/usb/host/xhci.h
 +++ b/drivers/usb/host/xhci.h
-@@ -1856,6 +1856,7 @@ struct xhci_hcd {
+@@ -1865,6 +1865,7 @@ struct xhci_hcd {
  #define XHCI_ZERO_64B_REGS    BIT_ULL(32)
  #define XHCI_RESET_PLL_ON_DISCONNECT  BIT_ULL(34)
  #define XHCI_SNPS_BROKEN_SUSPEND    BIT_ULL(35)
index 6db6112b79d094c8d72f3b2540a62752b0924a62..1079d94fe300f0b6c251866fb24d6129f0280ad9 100644 (file)
@@ -39,7 +39,7 @@ Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
 
 --- a/net/netfilter/xt_FLOWOFFLOAD.c
 +++ b/net/netfilter/xt_FLOWOFFLOAD.c
-@@ -338,10 +338,41 @@ static void xt_flowoffload_table_cleanup
+@@ -343,10 +343,41 @@ static void xt_flowoffload_table_cleanup
        nf_flow_table_free(table);
  }
  
@@ -81,7 +81,7 @@ Signed-off-by: Chen Minqiang <ptpt52@gmail.com>
        INIT_DELAYED_WORK(&hook_work, xt_flowoffload_hook_work);
  
        ret = xt_flowoffload_table_init(&nf_flowtable);
-@@ -359,6 +390,7 @@ static void __exit xt_flowoffload_tg_exi
+@@ -364,6 +395,7 @@ static void __exit xt_flowoffload_tg_exi
  {
        xt_unregister_target(&offload_tg_reg);
        xt_flowoffload_table_cleanup(&nf_flowtable);
index 5890483ae4ebe4665ab72f3ef2ca3110a603b281..d8ad40be615cac961ccfea15e48ecb5d6a1bc70a 100644 (file)
@@ -14,8 +14,8 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -654,12 +654,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
- KBUILD_CFLAGS += $(call cc-disable-warning, int-in-bool-context)
+@@ -655,12 +655,12 @@ KBUILD_CFLAGS    += $(call cc-disable-warni
+ KBUILD_CFLAGS += $(call cc-disable-warning, address-of-packed-member)
  
  ifdef CONFIG_CC_OPTIMIZE_FOR_SIZE
 -KBUILD_CFLAGS += -Os $(call cc-disable-warning,maybe-uninitialized,)