orion: fix initramfs uImage generation
authorFlorian Fainelli <florian@openwrt.org>
Tue, 1 Apr 2014 22:20:49 +0000 (22:20 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 1 Apr 2014 22:20:49 +0000 (22:20 +0000)
We would fail to copy an non-existent uImage-initramfs to $(BIN_DIR)

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40358

target/linux/orion/image/generic.mk

index 4e537061927a7a6f6be9520b02d2fa847b49eadd..5cf232c0ad9a3ea75bc19c92c3acf3a797d930d1 100644 (file)
@@ -83,7 +83,7 @@ define Image/BuildKernel/ARM/uImage
        # $(BOARD) kernel uImage for $(1)
        '$(STAGING_DIR_HOST)/bin/mkimage' -A arm -O linux -T kernel \
        -C none -a 0x00008000 -e 0x00008000 -n 'Linux-$(LINUX_VERSION)' \
-       -d '$(KDIR)/$(1)-zImage' '$(KDIR)/$(1)-uImage'
+       -d '$(KDIR)/$(1)-zImage$(2)' '$(KDIR)/$(1)-uImage$(2)'
  ifeq ($(2),-initramfs) # only copy uImage for ramdisk build
        cp '$(KDIR)/$(1)-uImage-initramfs' '$(BIN_DIR)/openwrt-$(1)-uImage-initramfs'
  endif