block-extroot: Added md5sum to extroot and underlying root filesystem. This is used...
authorDaniel Dickinson <crazycshore@gmail.com>
Fri, 3 Dec 2010 20:01:23 +0000 (20:01 +0000)
committerDaniel Dickinson <crazycshore@gmail.com>
Fri, 3 Dec 2010 20:01:23 +0000 (20:01 +0000)
SVN-Revision: 24230

package/block-extroot/Makefile
package/block-extroot/files/50_determine_usb_root
package/block-extroot/files/55_determine_extroot_sysupgrade [new file with mode: 0644]

index f1e093bcc30b7d9a99000baca29c7b054f2e8c97..05d5e18a1ab51ffd45abb769dff17abe1ccf1242 100644 (file)
@@ -53,6 +53,7 @@ define Package/block-extroot/install
        $(INSTALL_DATA) ./files/extmount.sh $(1)/lib/functions/
        $(INSTALL_DIR) $(1)/lib/preinit
        $(INSTALL_DATA) ./files/50_determine_usb_root $(1)/lib/preinit/
+       $(INSTALL_DATA) ./files/55_determine_extroot_sysupgrade $(1)/lib/preinit/
        $(INSTALL_DATA) ./files/60_pivot_usb_root $(1)/lib/preinit/
        $(INSTALL_DIR) $(1)/lib/preinit
        echo "extroot_settle_time=\"$(CONFIG_EXTROOT_SETTLETIME)\"" >$(1)/lib/preinit/00_extroot.conf
index b899203e5d408443aa9633572555c7fb658973f7..e87855c2a7777a502007cbec8adbe88748cbba20 100644 (file)
@@ -18,6 +18,7 @@ determine_external_root() {
        if [ "$jffs" = "/tmp/overlay" ] && [ -r "/tmp/overlay/etc/config/fstab" ]; then
                UCI_CONFIG_DIR="/tmp/overlay/etc/config"
                ER_IS_SQUASHFS=true
+               ER_OVERLAY_PREFIX="/tmp/overlay"
        fi
 
        # For squashfs on firstboot root_device will be tmpfs for the ramoverlay,
diff --git a/package/block-extroot/files/55_determine_extroot_sysupgrade b/package/block-extroot/files/55_determine_extroot_sysupgrade
new file mode 100644 (file)
index 0000000..21af8b0
--- /dev/null
@@ -0,0 +1,55 @@
+#!/bin/sh
+# Copyright (C) 2010 Daniel Dickinson
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+
+
+check_set_md5sum() {
+       local er_md5sum_file
+       er_md5sum_file="${ER_OVERLAY_PREFIX}/.extroot.md5sum"
+
+       local er_extroot_md5sum
+       if [ -f $md5sum_file ]; then
+               er_extroot_md5sum="$(cat $er_md5sum_file)"
+       fi
+
+       local er_extroot_overlay_md5sum
+       if [ -f "/overlay/etc/extroot.md5sum" ]; then
+               er_extroot_overlay_md5sum="$(cat /overlay/.extroot.md5sum)"
+       fi
+
+       if [ -z "$er_extroot_overlay_md5sum" ]; then
+               cat $er_md5sum_file >/overlay/.extroot.md5sum
+       elif [ "$er_extroot_overlay_md5sum" != "$er_extroot_md5sum" ]; then
+               pi_extroot_mount_success="false"
+               mkdir -p /tmp/overlay-disabled
+               mount --move /overlay /tmp/overlay-disabled
+       fi
+}
+
+set_jffs_md5sum() {
+       # We do this anytime block-extroot exists, even on the first boot with
+       # no extroot defined.
+
+       local er_md5sum_file
+       er_md5sum_file="${ER_OVERLAY_PREFIX}/.extroot.md5sum"
+
+       local er_extroot_md5sum
+       if [ -f $er_md5sum_file ]; then
+               er_extroot_md5sum="$(cat $er_md5sum_file)"
+       fi
+       if [ -z "$er_extroot_md5sum" ]; then
+               dd if=/dev/urandom count=32 bs=1k 2>/dev/null | md5sum | cut -f1 -d\  >$er_md5sum_file
+       fi
+}
+
+determine_extroot_sysupgrade() {
+       check_skip || set_jffs_md5sum
+
+       check_skip || [ "$pi_extroot_mount_success" != "true" ] || {
+               check_set_md5sum
+       }
+}
+
+boot_hook_add preinit_mount_root determine_extroot_sysupgrade
+