kernel: fix packaging of 8250.ko with Linux 3.x This commit fixes build breakage...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 25 Apr 2012 13:43:15 +0000 (13:43 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 25 Apr 2012 13:43:15 +0000 (13:43 +0000)
SVN-Revision: 31477

package/kernel/modules/other.mk

index abac4811d49f79dde282767647990b112bbee4c1..d3450cf73bafbf725f062c4d6df48f0e0efbf393 100644 (file)
@@ -896,7 +896,15 @@ define KernelPackage/serial-8250
        CONFIG_SERIAL_8250_SHARE_IRQ=y \
        CONFIG_SERIAL_8250_DETECT_IRQ=n \
        CONFIG_SERIAL_8250_RSA=n
+ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.3)),1)
+  FILES:=$(LINUX_DIR)/drivers/tty/serial/8250/8250.ko
+else
+ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,2.6.38)),1)
   FILES:=$(LINUX_DIR)/drivers/tty/serial/8250.ko
+ else
+  FILES:=$(LINUX_DIR)/drivers/serial/8250.ko
+ endif
+endif
 endef
 
 define KernelPackage/serial-8250/description