base-files: add permission exceptions, do not clobber shadow permissions - based...
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jun 2012 18:02:00 +0000 (18:02 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 5 Jun 2012 18:02:00 +0000 (18:02 +0000)
SVN-Revision: 32073

include/image.mk
package/base-files/Makefile

index 473e391ae4d414f09c0fb9678ece849922890e4f..b0d6dfae610df3bd63516f22d0f8029a8bb7af30 100644 (file)
@@ -142,7 +142,7 @@ endif
 
 define Image/mkfs/prepare/default
        # Use symbolic permissions to avoid clobbering SUID/SGID/sticky bits
-       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
+       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -not -name 'shadow' -print0 | $(XARGS) -0 chmod u+rw,g+r,o+r
        - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
        - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
index 68c8e0233bec2c3e2b20f61a58f5687f057218a3..88167b788bffc64b62f9999fa2ed1a8309383bfd 100644 (file)
@@ -470,6 +470,10 @@ define Package/base-files/install
        ln -sf /tmp $(1)/var
        mkdir -p $(1)/etc
        ln -sf /tmp/resolv.conf /tmp/fstab /tmp/TZ $(1)/etc/
+
+       chmod 0600 $(1)/etc/shadow
+       chmod 1777 $(1)/tmp
+
        $(call ImageConfigOptions,$(1))
        $(call Package/base-files/install-target,$(1))
        for conffile in $(1)/etc/config/*; do \