ramips: build image for Airlive AIR3GII
authorGabor Juhos <juhosg@openwrt.org>
Sat, 29 Dec 2012 17:50:34 +0000 (17:50 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sat, 29 Dec 2012 17:50:34 +0000 (17:50 +0000)
Signed-off-by: Cezary Jackiewicz <cezary.jackiewicz@gmail.com>
Patchwork: http://patchwork.openwrt.org/patch/2913/
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34924

target/linux/ramips/image/Makefile

index e7f78c9dfc5de87646346a9d59a3dd4d4ae242e0..f5eac7a7f6854a9c37293e250b841400f9d861e7 100644 (file)
@@ -456,6 +456,10 @@ define Image/Build/Profile/3G6200N
        $(call Image/Build/Template/$(fs_squash)/$(1),3G6200N,3g-6200n,3G-6200N,ttyS1,57600,phys)
 endef
 
+define Image/Build/Profile/AIR3GII
+       $(call Image/Build/Template/$(fs_squash)/$(1),GENERIC_4M,air3gii,AIR3GII,ttyS1,57600,spi)
+endef
+
 define Image/Build/Profile/ALL02393G
        $(call Image/Build/Template/$(fs_squash)/$(1),UIMAGE_8M,all0239-3g,ALL0239-3G,ttyS1,57600,phys)
 endef
@@ -619,6 +623,7 @@ endef
 ifeq ($(CONFIG_RALINK_RT305X),y)
 define Image/Build/Profile/Default
        $(call Image/Build/Profile/3G6200N,$(1))
+       $(call Image/Build/Profile/AIR3GII,$(1))
        $(call Image/Build/Profile/ALL02393G,$(1))
        $(call Image/Build/Profile/ALL0256N,$(1))
        $(call Image/Build/Profile/ALL5002,$(1))