Use common rules and templates, uniformize package Makefile, move ipkg related files...
authorNicolas Thill <nico@openwrt.org>
Mon, 18 Apr 2005 06:33:29 +0000 (06:33 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 18 Apr 2005 06:33:29 +0000 (06:33 +0000)
SVN-Revision: 664

16 files changed:
openwrt/package/pcre/Config.in
openwrt/package/pcre/Makefile
openwrt/package/pcre/ipkg/libpcre-dev/CONTROL/control [deleted file]
openwrt/package/pcre/ipkg/libpcre.control [new file with mode: 0644]
openwrt/package/pcre/ipkg/libpcre/CONTROL/control [deleted file]
openwrt/package/pcre/ipkg/rules [deleted file]
openwrt/package/pcre/ipkg/version [deleted file]
openwrt/package/pcre/libpcre.control [deleted file]
openwrt/package/popt/Config.in
openwrt/package/popt/Makefile
openwrt/package/popt/ipkg/libpopt-dev/CONTROL/control [deleted file]
openwrt/package/popt/ipkg/libpopt.control [new file with mode: 0644]
openwrt/package/popt/ipkg/libpopt/CONTROL/control [deleted file]
openwrt/package/popt/ipkg/rules [deleted file]
openwrt/package/popt/ipkg/version [deleted file]
openwrt/package/popt/libpopt.control [deleted file]

index 3aa16d7fdc9258e00a84981bf0f20eb674f52756..370fc763f37b337adae3061799f681f5cc2d4f97 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_PCRE
-       tristate "pcre"
+       prompt "pcre"
+       tristate
        default m
        help
          A Perl Compatible Regular Expression library
@@ -7,3 +8,7 @@ config BR2_PACKAGE_PCRE
          http://www.pcre.org/
          
 
+config BR2_PACKAGE_LIBPCRE
+       tristate
+       default BR2_PACKAGE_PCRE
+
index f0741065272fa77a2d7bc1cf5d3c87078657757a..b5ebd80d792ad1a18c5744bdb3d9cd1d42f6ba34 100644 (file)
@@ -7,28 +7,26 @@ PKG_VERSION:=5.0
 PKG_RELEASE:=3
 PKG_MD5SUM:=53976b62032fd5c76678274e5fd196b4
 
-PKG_SOURCE_URL:=\
+PKG_SOURCE_URL:= \
        ftp://ftp.csx.cam.ac.uk/pub/software/programming/pcre/ \
        http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-IPKG_LIBPCRE:=$(PACKAGE_DIR)/lib$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_LIBPCRE:=$(PKG_BUILD_DIR)/ipkg/lib$(PKG_NAME)
-INFO_LIBPCRE:=$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
+include $(TOPDIR)/package/templates.mk
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+$(eval $(call PKG_template,LIBPCRE,libpcre,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-#      $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.prepared
+include $(TOPDIR)/package/rules.mk
+
+COMPILE_TARGETS += install-dev
+CLEAN_TARGETS += uninstall-dev
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache config.status; \
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status}; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
@@ -67,8 +65,7 @@ $(PKG_BUILD_DIR)/.built: $(PKG_BUILD_DIR)/.configured
                dftables
        $(MAKE) \
                $(TARGET_CONFIGURE_OPTS) \
-               CFLAGS="$(TARGET_CFLAGS)" \
-         
+               CFLAGS="$(TARGET_CFLAGS)"
        touch $(PKG_BUILD_DIR)/.built
 
 $(STAGING_DIR)/usr/lib/libpcre.so: $(PKG_BUILD_DIR)/.built
@@ -77,27 +74,19 @@ $(STAGING_DIR)/usr/lib/libpcre.so: $(PKG_BUILD_DIR)/.built
                install
        rm -f $(STAGING_DIR)/usr/lib/libpcre*.la
 
-$(IPKG_LIBPCRE): $(STAGING_DIR)/usr/lib/libpcre.so
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBPCRE) lib$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+$(IPKG_LIBPCRE): $(IDIR_LIBPCRE)/CONTROL/control $(STAGING_DIR)/usr/lib/libpcre.so
        mkdir -p $(IDIR_LIBPCRE)/usr/lib
-       cp -fp $(STAGING_DIR)/usr/lib/libpcre*.so.* $(IDIR_LIBPCRE)/usr/lib/
-       $(STRIP) $(IDIR_LIBPCRE)/usr/lib/lib*.so*
+       cp -fpR $(STAGING_DIR)/usr/lib/libpcre*.so.* $(IDIR_LIBPCRE)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBPCRE)
        mkdir -p $(PACKAGE_DIR)
        $(IPKG_BUILD) $(IDIR_LIBPCRE) $(PACKAGE_DIR)
 
-$(INFO_LIBPCRE): $(IPKG_LIBPCRE)
-       $(IPKG) install $(IPKG_LIBPCRE)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(IPKG_LIBPCRE)
-install: $(INFO_LIBPCRE)
+install-dev: $(STAGING_DIR)/usr/lib/libpcre.so
 
-clean:
+uninstall-dev:
        rm -rf \
          $(STAGING_DIR)/usr/bin/pcre-config \
          $(STAGING_DIR)/usr/include/pcre* \
          $(STAGING_DIR)/usr/lib/libpcre* \
          $(STAGING_DIR)/usr/lib/pkgconfig/libpcre.pc \
          $(STAGING_DIR)/usr/share/man/man*/pcre* \
-         $(PKG_BUILD_DIR) $(IPKG_LIBPCRE)
diff --git a/openwrt/package/pcre/ipkg/libpcre-dev/CONTROL/control b/openwrt/package/pcre/ipkg/libpcre-dev/CONTROL/control
deleted file mode 100644 (file)
index 1718885..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: libpcre-dev
-Priority: optional
-Section: devel
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/pcre/
-Description: a Perl Compatible Regular Expression library (development)
diff --git a/openwrt/package/pcre/ipkg/libpcre.control b/openwrt/package/pcre/ipkg/libpcre.control
new file mode 100644 (file)
index 0000000..2bda390
--- /dev/null
@@ -0,0 +1,8 @@
+Package: libpcre
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/pcre/
+Description: a Perl Compatible Regular Expression library
diff --git a/openwrt/package/pcre/ipkg/libpcre/CONTROL/control b/openwrt/package/pcre/ipkg/libpcre/CONTROL/control
deleted file mode 100644 (file)
index 2bda390..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: libpcre
-Priority: optional
-Section: libs
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/pcre/
-Description: a Perl Compatible Regular Expression library
diff --git a/openwrt/package/pcre/ipkg/rules b/openwrt/package/pcre/ipkg/rules
deleted file mode 100644 (file)
index ead5116..0000000
+++ /dev/null
@@ -1,141 +0,0 @@
-#!/usr/bin/make -f
-
-ifneq ($(strip ${IPKG_RULES_INC}),)
- include $(IPKG_RULES_INC)
-endif
-
-##
-
-PKG_VERSION := $(shell cat ./ipkg/version)
-CURRENT_DIR := $(shell pwd)
-INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
-
-unexport INSTALL_DIR
-
-I_LIBPCRE := ipkg/libpcre
-I_LIBPCRE_DEV := ipkg/libpcre-dev
-
-BUILD_DEPS := \
-
-CONFIGURE_OPTS = \
-       --enable-shared \
-       --enable-static \
-       --enable-utf8 \
-
-##
-
-all: package
-
-
-.stamp-configured: $(BUILD_DEPS)
-
-       rm -rf config.cache
-       $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       ./configure \
-         --target=$(GNU_TARGET_NAME) \
-         --host=$(GNU_TARGET_NAME) \
-         --build=$(GNU_HOST_NAME) \
-         --prefix=/usr \
-         --exec-prefix=/usr \
-         --bindir=/usr/bin \
-         --datadir=/usr/share \
-         --includedir=/usr/include \
-         --infodir=/usr/share/info \
-         --libdir=/usr/lib \
-         --libexecdir=/usr/lib \
-         --localstatedir=/var \
-         --mandir=/usr/share/man \
-         --sbindir=/usr/sbin \
-         --sysconfdir=/etc \
-         $(DISABLE_LARGEFILE) \
-         $(DISABLE_NLS) \
-         $(CONFIGURE_OPTS) \
-
-       touch .stamp-configured
-
-
-.stamp-built: .stamp-configured
-
-       $(MAKE) \
-         CC_FOR_BUILD="$(HOSTCC)" \
-         LINK_FOR_BUILD="$(HOSTCC)" \
-         CFLAGS_FOR_BUILD="" \
-        dftables
-
-       $(MAKE) \
-         $(TARGET_CONFIGURE_OPTS) \
-         CFLAGS="$(TARGET_CFLAGS)" \
-         
-       touch .stamp-built
-
-
-$(INSTALL_DIR)/usr/include/pcre.h: .stamp-built
-
-       mkdir -p $(INSTALL_DIR)
-
-       $(MAKE) \
-         DESTDIR="$(INSTALL_DIR)" \
-        install
-
-       rm -f $(INSTALL_DIR)/usr/lib/libpcre*.la
-
-
-configure: .stamp-configured
-
-
-build: .stamp-built
-
-
-install: $(INSTALL_DIR)/usr/include/pcre.h
-
-
-package: $(INSTALL_DIR)/usr/include/pcre.h
-
-       mkdir -p $(I_LIBPCRE)/usr/lib
-       cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.so.* $(I_LIBPCRE)/usr/lib/
-       $(STRIP) $(I_LIBPCRE)/usr/lib/lib*.so.*
-
-       mkdir -p $(I_LIBPCRE_DEV)/usr/bin
-       cp -fpR $(INSTALL_DIR)/usr/bin/pcre-config  $(I_LIBPCRE_DEV)/usr/bin/
-       mkdir -p $(I_LIBPCRE_DEV)/usr/include
-       cp -fpR $(INSTALL_DIR)/usr/include/pcre*.h $(I_LIBPCRE_DEV)/usr/include/
-       mkdir -p $(I_LIBPCRE_DEV)/usr/lib
-       cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.a $(I_LIBPCRE_DEV)/usr/lib/
-       cp -fpR $(INSTALL_DIR)/usr/lib/libpcre*.so* $(I_LIBPCRE_DEV)/usr/lib/
-
-       chmod 0755 ipkg/*/CONTROL/
-       chmod 0644 ipkg/*/CONTROL/control
-       
-       perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
-ifneq ($(strip $(PKG_VERSION)),)
-       perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
-endif
-
-       $(IPKG_BUILD) $(I_LIBPCRE) $(IPKG_TARGET_DIR)
-       $(IPKG_BUILD) $(I_LIBPCRE_DEV) $(IPKG_TARGET_DIR)
-
-
-clean:
-
-       -$(MAKE) clean
-
-       rm -rf .stamp-* \
-         $(INSTALL_DIR)/usr/bin/pcre* \
-         $(INSTALL_DIR)/usr/include/pcre* \
-         $(INSTALL_DIR)/usr/lib/libpcre* \
-         $(INSTALL_DIR)/usr/lib/pkgconfig/libpcre.pc \
-         $(INSTALL_DIR)/usr/share/man/man*/pcre* \
-         $(I_LIBPCRE)/usr \
-        $(I_LIBPCRE_DEV)/usr \
-
-
-control:
-
-       @cat $(I_LIBPCRE)/CONTROL/control
-       @echo
-       @cat $(I_LIBPCRE_DEV)/CONTROL/control
-       @echo
-       
-
-.PHONY: configure build install package clean control
diff --git a/openwrt/package/pcre/ipkg/version b/openwrt/package/pcre/ipkg/version
deleted file mode 100644 (file)
index 2f5e55b..0000000
+++ /dev/null
@@ -1 +0,0 @@
-5.0-3
diff --git a/openwrt/package/pcre/libpcre.control b/openwrt/package/pcre/libpcre.control
deleted file mode 100644 (file)
index 2bda390..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: libpcre
-Priority: optional
-Section: libs
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/pcre/
-Description: a Perl Compatible Regular Expression library
index 291e69330bef479b8f2ef701db4abb81450cd3a6..9f61204d5c6565b853e2b3213ca18e9d7848fc53 100644 (file)
@@ -1,5 +1,6 @@
 config BR2_PACKAGE_POPT
-       tristate "popt (a command line option parsing library)"
+       prompt "popt"
+       tristate 
        default m
        help
          A command line option parsing library
@@ -7,3 +8,7 @@ config BR2_PACKAGE_POPT
          ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/
          
 
+config BR2_PACKAGE_LIBPOPT
+       tristate
+       default BR2_PACKAGE_POPT
+
index 5d67b80c1468f8750bcf0ba8fa688cca00d5615f..7297ce7b01fc157ab1d8e92e04d393b08c9ad7f1 100644 (file)
@@ -7,28 +7,26 @@ PKG_VERSION:=1.7
 PKG_RELEASE:=4
 PKG_MD5SUM:=5988e7aeb0ae4dac8d83561265984cc9
 
-PKG_SOURCE_URL:=\
+PKG_SOURCE_URL:= \
        ftp://ftp.rpm.org/pub/rpm/dist/rpm-4.1.x/ \
        http://nthill.free.fr/openwrt/sources/$(PKG_NAME)/
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_CAT:=zcat
 
 PKG_BUILD_DIR:=$(BUILD_DIR)/$(PKG_NAME)-$(PKG_VERSION)
+PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
-IPKG_LIBPOPT:=$(PACKAGE_DIR)/lib$(PKG_NAME)_$(PKG_VERSION)-$(PKG_RELEASE)_$(ARCH).ipk
-IDIR_LIBPOPT:=$(PKG_BUILD_DIR)/ipkg/lib$(PKG_NAME)
-INFO_LIBPOPT:=$(IPKG_STATE_DIR)/info/lib$(PKG_NAME).list
+include $(TOPDIR)/package/templates.mk
 
-$(DL_DIR)/$(PKG_SOURCE):
-       $(SCRIPT_DIR)/download.pl $(DL_DIR) $(PKG_SOURCE) $(PKG_MD5SUM) $(PKG_SOURCE_URL)
+$(eval $(call PKG_template,LIBPOPT,libpopt,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
-$(PKG_BUILD_DIR)/.prepared: $(DL_DIR)/$(PKG_SOURCE)
-       $(PKG_CAT) $(DL_DIR)/$(PKG_SOURCE) | tar -C $(BUILD_DIR) $(TAR_OPTIONS) -
-#      $(PATCH) $(PKG_BUILD_DIR) ./patches
-       touch $(PKG_BUILD_DIR)/.prepared
+include $(TOPDIR)/package/rules.mk
+
+COMPILE_TARGETS += install-dev
+CLEAN_TARGETS += uninstall-dev
 
 $(PKG_BUILD_DIR)/.configured: $(PKG_BUILD_DIR)/.prepared
-       (cd $(PKG_BUILD_DIR); rm -rf config.cache config.status; \
+       (cd $(PKG_BUILD_DIR); rm -rf config.{cache,status} ; \
                $(TARGET_CONFIGURE_OPTS) \
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include" \
@@ -68,24 +66,16 @@ $(STAGING_DIR)/usr/lib/libpopt.so: $(PKG_BUILD_DIR)/.built
                install
        rm -f $(STAGING_DIR)/usr/lib/libpopt.la
 
-$(IPKG_LIBPOPT): $(STAGING_DIR)/usr/lib/libpopt.so
-       $(SCRIPT_DIR)/make-ipkg-dir.sh $(IDIR_LIBPOPT) lib$(PKG_NAME).control $(PKG_VERSION)-$(PKG_RELEASE) $(ARCH)
+$(IPKG_LIBPOPT): $(IDIR_LIBPOPT)/CONTROL/control $(STAGING_DIR)/usr/lib/libpopt.so
        mkdir -p $(IDIR_LIBPOPT)/usr/lib
-       cp -fp $(STAGING_DIR)/usr/lib/libpopt.so.* $(IDIR_LIBPOPT)/usr/lib/
-       $(STRIP) $(IDIR_LIBPOPT)/usr/lib/*.so*
+       cp -fpR $(STAGING_DIR)/usr/lib/libpopt.so.* $(IDIR_LIBPOPT)/usr/lib/
+       $(RSTRIP) $(IDIR_LIBPOPT)
        mkdir -p $(PACKAGE_DIR)
        $(IPKG_BUILD) $(IDIR_LIBPOPT) $(PACKAGE_DIR)
 
-$(INFO_LIBPOPT): $(IPKG_LIBPOPT)
-       $(IPKG) install $(IPKG_LIBPOPT)
-
-source: $(DL_DIR)/$(PKG_SOURCE)
-prepare: $(PKG_BUILD_DIR)/.prepared
-compile: $(IPKG_LIBPOPT)
-install: $(INFO_LIBPOPT)
+install-dev: $(STAGING_DIR)/usr/lib/libpopt.so
 
-clean:
+uninstall-dev:
        -$(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(STAGING_DIR)" \
                uninstall
-       rm -rf $(PKG_BUILD_DIR) $(IPKG_LIBPOPT)
diff --git a/openwrt/package/popt/ipkg/libpopt-dev/CONTROL/control b/openwrt/package/popt/ipkg/libpopt-dev/CONTROL/control
deleted file mode 100644 (file)
index 47faa7a..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: libpopt-dev
-Priority: optional
-Section: devel
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/popt/
-Description: a command line option parsing library (development)
diff --git a/openwrt/package/popt/ipkg/libpopt.control b/openwrt/package/popt/ipkg/libpopt.control
new file mode 100644 (file)
index 0000000..b932c4a
--- /dev/null
@@ -0,0 +1,8 @@
+Package: libpopt
+Priority: optional
+Section: libs
+Version: [TBDL]
+Architecture: [TBDL]
+Maintainer: Nico <nthill@free.fr>
+Source: http://nthill.free.fr/openwrt/sources/popt/
+Description: a command line option parsing library
diff --git a/openwrt/package/popt/ipkg/libpopt/CONTROL/control b/openwrt/package/popt/ipkg/libpopt/CONTROL/control
deleted file mode 100644 (file)
index b932c4a..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: libpopt
-Priority: optional
-Section: libs
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/popt/
-Description: a command line option parsing library
diff --git a/openwrt/package/popt/ipkg/rules b/openwrt/package/popt/ipkg/rules
deleted file mode 100644 (file)
index 7a615a5..0000000
+++ /dev/null
@@ -1,130 +0,0 @@
-#!/usr/bin/make -f
-
-ifneq ($(strip ${IPKG_RULES_INC}),)
- include $(IPKG_RULES_INC)
-endif
-
-##
-
-PKG_VERSION := $(shell cat ./ipkg/version)
-CURRENT_DIR := $(shell pwd)
-INSTALL_DIR ?= $(CURRENT_DIR)/ipkg-install
-
-unexport INSTALL_DIR
-
-I_LIBPOPT := ipkg/libpopt
-I_LIBPOPT_DEV := ipkg/libpopt-dev
-
-BUILD_DEPS := \
-
-CONFIGURE_OPTS = \
-       --enable-shared \
-       --enable-static \
-
-##
-
-all: package
-
-
-.stamp-configured: $(BUILD_DEPS)
-
-       rm -rf config.cache
-       $(TARGET_CONFIGURE_OPTS) \
-       CFLAGS="$(TARGET_CFLAGS)" \
-       am_cv_func_iconv=no \
-       ./configure \
-         --target=$(GNU_TARGET_NAME) \
-         --host=$(GNU_TARGET_NAME) \
-         --build=$(GNU_HOST_NAME) \
-         --program-prefix="" \
-         --program-suffix="" \
-         --prefix=/usr \
-         --exec-prefix=/usr \
-         --bindir=/usr/bin \
-         --datadir=/usr/share \
-         --includedir=/usr/include \
-         --infodir=/usr/share/info \
-         --libdir=/usr/lib \
-         --libexecdir=/usr/lib \
-         --localstatedir=/var \
-         --mandir=/usr/share/man \
-         --sbindir=/usr/sbin \
-         --sysconfdir=/etc \
-         $(DISABLE_LARGEFILE) \
-         $(DISABLE_NLS) \
-         $(CONFIGURE_OPTS) \
-
-       touch .stamp-configured
-
-
-.stamp-built: .stamp-configured
-
-       $(MAKE)
-         
-       touch .stamp-built
-
-
-$(INSTALL_DIR)/usr/include/popt.h: .stamp-built
-
-       mkdir -p $(INSTALL_DIR)
-
-       $(MAKE) \
-         DESTDIR="$(INSTALL_DIR)" \
-        install
-
-       rm -f $(INSTALL_DIR)/usr/lib/libpopt.la
-
-
-configure: .stamp-configured
-
-
-build: .stamp-built
-
-
-install: $(INSTALL_DIR)/usr/include/popt.h
-
-
-package: $(INSTALL_DIR)/usr/include/popt.h
-
-       mkdir -p $(I_LIBPOPT)/usr/lib
-       cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so.* $(I_LIBPOPT)/usr/lib/
-       $(STRIP) $(I_LIBPOPT)/usr/lib/lib*.so.*
-
-       mkdir -p $(I_LIBPOPT_DEV)/usr/include
-       cp -fpR $(INSTALL_DIR)/usr/include/popt.h $(I_LIBPOPT_DEV)/usr/include/
-       mkdir -p $(I_LIBPOPT_DEV)/usr/lib
-       cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.a $(I_LIBPOPT_DEV)/usr/lib/
-       cp -fpR $(INSTALL_DIR)/usr/lib/libpopt*.so* $(I_LIBPOPT_DEV)/usr/lib/
-
-       chmod 0755 ipkg/*/CONTROL/
-       chmod 0644 ipkg/*/CONTROL/control
-       
-       perl -pi -e "s/^Arch.*:.*/Architecture: $(ARCH)/g" ipkg/*/CONTROL/control
-ifneq ($(strip $(PKG_VERSION)),)
-       perl -pi -e "s/^Vers.*:.*/Version: $(PKG_VERSION)/g" ipkg/*/CONTROL/control
-endif
-
-       $(IPKG_BUILD) $(I_LIBPOPT) $(IPKG_TARGET_DIR)
-       $(IPKG_BUILD) $(I_LIBPOPT_DEV) $(IPKG_TARGET_DIR)
-
-
-clean:
-
-       -$(MAKE) \
-         DESTDIR="$(INSTALL_DIR)" \
-        uninstall clean
-
-       rm -rf .stamp-* \
-         $(I_LIBPOPT)/usr \
-         $(I_LIBPOPT_DEV)/usr \
-
-
-control:
-
-       @cat $(I_LIBPOPT)/CONTROL/control
-       @echo
-       @cat $(I_LIBPOPT_DEV)/CONTROL/control
-       @echo
-       
-
-.PHONY: configure build install package clean control
diff --git a/openwrt/package/popt/ipkg/version b/openwrt/package/popt/ipkg/version
deleted file mode 100644 (file)
index 75b1827..0000000
+++ /dev/null
@@ -1 +0,0 @@
-1.7-4
diff --git a/openwrt/package/popt/libpopt.control b/openwrt/package/popt/libpopt.control
deleted file mode 100644 (file)
index b932c4a..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-Package: libpopt
-Priority: optional
-Section: libs
-Version: [TBDL]
-Architecture: [TBDL]
-Maintainer: Nico <nthill@free.fr>
-Source: http://nthill.free.fr/openwrt/sources/popt/
-Description: a command line option parsing library