ramips: select kmod-mt76x0e for TP-Link ArcherC20i and wr902ac-v3
authorDaniel Golle <daniel@makrotopia.org>
Sun, 25 Nov 2018 13:35:49 +0000 (14:35 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 25 Nov 2018 14:24:49 +0000 (15:24 +0100)
Both devices come with a MediaTek MT7610E 5GHz 802.11ac 1T1R radio
which wasn't supported at the time the devices were added to OpenWrt.
Now that we got it, include kmod-mt76x0e in images for those devices.

Reported-by: Arian Sanusi <openwrt@semioptimal.net>
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/ramips/image/mt7620.mk
target/linux/ramips/image/mt76x8.mk

index b0d2b2a8f90df4f289d2d46e79c8c2cbfa30023e..b5d73f60c7e804239eae84c880984812ee570393 100644 (file)
@@ -49,6 +49,7 @@ define Device/ArcherC20i
   TPLINK_HWID := 0xc2000001
   TPLINK_HWREV := 58
   IMAGES += factory.bin
+  DEVICE_PACKAGES := kmod-mt76x0e
   DEVICE_TITLE := TP-Link ArcherC20i
 endef
 TARGET_DEVICES += ArcherC20i
index 16fbad2bbcd5bb20b402456f67caa99536dbc731..6bedb4f7d420576227e4ea937765681fc77582f7 100644 (file)
@@ -283,7 +283,7 @@ define Device/tplink_tl-wr902ac-v3
   TPLINK_HWREV := 0x89
   TPLINK_HWREVADD := 0x1
   TPLINK_HVERSION := 3
-  DEVICE_PACKAGES := kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
+  DEVICE_PACKAGES := kmod-mt76x0e kmod-usb2 kmod-usb-ohci kmod-usb-ledtrig-usbport
 endef
 TARGET_DEVICES += tplink_tl-wr902ac-v3