dropbear: enable back DROPBEAR_USE_PASSWORD_ENV
authorKonstantin Demin <rockdrilla@gmail.com>
Tue, 24 Nov 2020 22:54:05 +0000 (01:54 +0300)
committerPetr Štetiar <ynezz@true.cz>
Fri, 11 Dec 2020 12:48:24 +0000 (13:48 +0100)
this option was disabled in 2011 and these long nine years showed us that change was definitely wrong.

binary size cost is much less than 1k.

tested on ath79/generic:
  bin: 215128 -> 215128 (no change)
  ipk: 111108 -> 111183 (+75b)

Fixes: 3c801b3dc0359 ("tune some more options by default to decrease size")
Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
package/network/services/dropbear/Makefile

index 8520426382b274f5de2cd4628928b2776745e692..727f1c16b04a7d31a35837f94451e4b25463fc67 100644 (file)
@@ -126,8 +126,7 @@ define Build/Configure
                $(PKG_BUILD_DIR)/sysoptions.h
 
        # disable legacy/unsafe methods and unused functionality
-       for OPTION in INETD_MODE DROPBEAR_CLI_NETCAT \
-       DROPBEAR_DSS DROPBEAR_USE_PASSWORD_ENV DO_MOTD ; do \
+       for OPTION in INETD_MODE DROPBEAR_CLI_NETCAT DROPBEAR_DSS DO_MOTD ; do \
                echo "#define $$$$OPTION 0" >> \
                        $(PKG_BUILD_DIR)/localoptions.h; \
        done