flex: Add a lex symlink
authorRosen Penev <rosenp@gmail.com>
Tue, 13 Nov 2018 20:59:47 +0000 (12:59 -0800)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 25 Nov 2018 18:23:03 +0000 (19:23 +0100)
Some packages like libpfring assume the presense of lex, which on some
other systems is a symlink to flex but not all. Symlink flex to fix
compilation.

Arch Linux and Fedora do this as far as I know.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
tools/flex/Makefile

index 1eff81f34515849baf75e09aaa132b7cd5322d37..bb5aecbdfeadeef0f3803c6e9678b1de5a31978e 100644 (file)
@@ -21,6 +21,11 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_ARGS += --disable-shared
 
+define Host/Install
+       $(call Host/Install/Default)
+       $(LN) flex $(STAGING_DIR_HOST)/bin/lex
+endef
+
 define Host/Clean
        -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
        $(call Host/Clean/Default)