fix generation of falcon images for profiles
authorJohn Crispin <john@openwrt.org>
Thu, 7 Jul 2011 20:20:51 +0000 (20:20 +0000)
committerJohn Crispin <john@openwrt.org>
Thu, 7 Jul 2011 20:20:51 +0000 (20:20 +0000)
SVN-Revision: 27550

target/linux/lantiq/image/Makefile

index f0c06fd94efb18b274e372ed6e0bf6d97ee83819..473094655e4e773ea86026eb699b2398fdd7154a 100644 (file)
@@ -202,6 +202,22 @@ endef
 endif
 
 ifeq ($(CONFIG_TARGET_lantiq_falcon)$(CONFIG_TARGET_lantiq_falcon_stable),y)
+define Image/BuildKernel/Profile/EASY98000
+       $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
+endef
+
+define Image/Build/Profile/EASY98000
+       $(call Image/Build/$(1),$(1),EASY98000)
+endef
+
+define Image/BuildKernel/Profile/EASY98020
+       $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))
+endef
+
+define Image/Build/Profile/EASY98020
+       $(call Image/Build/$(1),$(1),EASY98020)
+endef
+
 define Image/BuildKernel/Profile/Generic
        $(call Image/BuildKernel/Template,EASY98000,$(falcon_cmdline))
        $(call Image/BuildKernel/Template,EASY98020,$(falcon_cmdline))