kernel: Build it87 hardware monitor module
authorDaniel Dickinson <lede@daniel.thecshore.com>
Wed, 18 May 2016 08:46:41 +0000 (04:46 -0400)
committerJo-Philipp Wich <jo@mein.io>
Wed, 18 May 2016 20:17:28 +0000 (22:17 +0200)
Add packaging of it87 hardware monitor kernel module.  It is
a common thermal and voltage monitor that is in many x86
(at least) devices, and is just another i2c hwmon module.

Signed-off-by: Daniel Dickinson <lede@daniel.thecshore.com>
package/kernel/linux/modules/hwmon.mk

index 69aaacd92f69e23055f776a02add5bb01d39c449..f7a92eda1ed940ce317a2adcf6b7ea956d079d11 100644 (file)
@@ -108,6 +108,20 @@ endef
 $(eval $(call KernelPackage,hwmon-ina2xx))
 
 
+define KernelPackage/hwmon-it87
+  TITLE:=IT87 monitoring support
+  KCONFIG:=CONFIG_SENSORS_IT87
+  FILES:=$(LINUX_DIR)/drivers/hwmon/it87.ko
+  AUTOLOAD:=$(call AutoProbe,it87)
+  $(call AddDepends/hwmon,+kmod-i2c-core +kmod-hwmon-vid +PACKAGE_kmod-thermal:kmod-thermal)
+endef
+
+define KernelPackage/hwmon-it87/description
+ Kernel module for it87 thermal and voltage monitor chip
+endef
+
+$(eval $(call KernelPackage,hwmon-it87))
+
 define KernelPackage/hwmon-lm63
   TITLE:=LM63/64 monitoring support
   KCONFIG:=CONFIG_SENSORS_LM63