linux-atm: add the kernel include dir to the cflags and move the build dir to $(KERNE...
authorFelix Fietkau <nbd@openwrt.org>
Sun, 28 Mar 2010 21:41:56 +0000 (21:41 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 28 Mar 2010 21:41:56 +0000 (21:41 +0000)
SVN-Revision: 20556

package/linux-atm/Makefile

index 07484c675fe20111d32607f37fec857cab9ee2a8..c8a18c3d31a120847bab42c41cbc6d0d4fc9e6f7 100644 (file)
@@ -6,6 +6,7 @@
 #
 
 include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=linux-atm
 PKG_VERSION:=2.5.1
@@ -46,6 +47,8 @@ define Build/Configure
        touch $(PKG_BUILD_DIR)/stamp-h.in
 endef
 
+TARGET_CFLAGS += -I$(LINUX_DIR)/include
+
 define Build/Compile
        # src/qgen is built with HOSTCC, which does not really like our LDFLAGS
        $(MAKE) -C $(PKG_BUILD_DIR)/src/qgen \