build: fix seq host tool check
authorJo-Philipp Wich <jo@mein.io>
Fri, 15 Mar 2019 18:23:31 +0000 (21:23 +0300)
committerJo-Philipp Wich <jo@mein.io>
Fri, 18 Oct 2019 17:48:49 +0000 (19:48 +0200)
Problem found on alpine linux when trying to `./scripts/feeds update -a`,
which results in `Build dependency: Missing seq command`.

Ref: https://github.com/openwrt/openwrt/pull/1926
Suggested-by: imShara <shara@protonmail.com>
[reworded commit and turned faulty Sob into Suggested-by]
Signed-off-by: Jo-Philipp Wich <jo@mein.io>
include/prereq-build.mk

index 0f2a35c93bbe39c78c2c17f2e332512af84a01f1..4c5991005634341da93294ce19f46781d0fc55de 100644 (file)
@@ -105,9 +105,9 @@ $(eval $(call SetupHostCommand,cp,Please install GNU fileutils, \
        gcp --help 2>&1 | grep 'Copy SOURCE', \
        cp --help 2>&1 | grep 'Copy SOURCE'))
 
-$(eval $(call SetupHostCommand,seq,, \
+$(eval $(call SetupHostCommand,seq,Please install seq, \
        gseq --version, \
-       seq --version))
+       seq --version 2>&1 | grep seq))
 
 $(eval $(call SetupHostCommand,awk,Please install GNU 'awk', \
        gawk --version 2>&1 | grep GNU, \