Add hostapd-mini to default images where applicable
authorAndy Boyett <agb@openwrt.org>
Fri, 2 Jan 2009 05:12:46 +0000 (05:12 +0000)
committerAndy Boyett <agb@openwrt.org>
Fri, 2 Jan 2009 05:12:46 +0000 (05:12 +0000)
SVN-Revision: 13819

19 files changed:
target/linux/adm5120/Makefile
target/linux/adm5120/router_le/profiles/Cellvision.mk
target/linux/adm5120/router_le/profiles/Edimax.mk
target/linux/ar71xx/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/au1000/profiles/InternetBox.mk
target/linux/au1000/profiles/MeshCube.mk
target/linux/brcm-2.4/profiles/120-Atheros.mk
target/linux/brcm47xx/Makefile
target/linux/brcm47xx/profiles/110-None.mk
target/linux/brcm63xx/Makefile
target/linux/ifxmips/Makefile
target/linux/ifxmips/profiles/000-None.mk
target/linux/ixp4xx/generic/profiles/200-NSLU2.mk
target/linux/ixp4xx/generic/profiles/500-USR8200.mk
target/linux/ixp4xx/generic/target.mk
target/linux/rb532/Makefile
target/linux/rdc/Makefile

index 9a601e47d556acec4ec1834963c9e1d6622fde32..4e63a0fcc9ebbeed442c051fef1f8edc7087496f 100644 (file)
@@ -15,11 +15,7 @@ INITRAMFS_EXTRA_FILES:=
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += admswconfig
-DEFAULT_PACKAGES += \
-       kmod-input-core \
-       kmod-input-polldev \
-       kmod-input-gpio-buttons \
-       kmod-button-hotplug
+DEFAULT_PACKAGES += admswconfig hostapd-mini kmod-input-core \
+                   kmod-input-polldev kmod-input-gpio-buttons kmod-button-hotplug
 
 $(eval $(call BuildTarget))
index 9c8356a663408c95d237070f59a3cc1355af8829..9fa1e02330e12cc9d1a8ba0fadfd0050f7bf9bf2 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007,2008 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -8,6 +8,7 @@
 define Profile/CAS630
        NAME:=Cellvision CAS-630 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630/Description
@@ -17,6 +18,7 @@ endef
 define Profile/CAS630W
        NAME:=Cellvision CAS-630W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS630W/Description
@@ -26,6 +28,7 @@ endef
 define Profile/CAS670
        NAME:=Cellvision CAS-670 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670/Description
@@ -35,6 +38,7 @@ endef
 define Profile/CAS670W
        NAME:=Cellvision CAS-670W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS670W/Description
@@ -44,6 +48,7 @@ endef
 define Profile/CAS700
        NAME:=Cellvision CAS-700 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700/Description
@@ -53,6 +58,7 @@ endef
 define Profile/CAS700W
        NAME:=Cellvision CAS-700W IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS700W/Description
@@ -61,7 +67,7 @@ endef
 
 define Profile/CAS771
        NAME:=Cellvision CAS-771 IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio
 endef
 
 define Profile/CAS771/Description
@@ -70,7 +76,7 @@ endef
 
 define Profile/CAS771W
        NAME:=Cellvision CAS-771W IP camera (Experimental)
-       PACKAGES:=kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
+       PACKAGES:=-hostapd-mini kmod-video-cpia2 kmod-usb-ohci kmod-usb2 kmod-usb-audio kmod-rt2500-pci
 endef
 
 define Profile/CAS771W/Description
@@ -80,6 +86,7 @@ endef
 define Profile/CAS790
        NAME:=Cellvision CAS-790 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS790/Description
@@ -89,6 +96,7 @@ endef
 define Profile/CAS861
        NAME:=Cellvision CAS-861 IP camera (Experimental)
        # TODO: add default packages
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/CAS861/Description
@@ -106,6 +114,7 @@ endef
 
 define Profile/NFS101U
        NAME:=Cellvision NFS-101U Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101U/Description
@@ -114,6 +123,7 @@ endef
 
 define Profile/NFS101WU
        NAME:=Cellvision NFS-101WU Network File Server (Experimental)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/NFS101WU/Description
index e4c427f570584451ebded5dcb2ef8dcedbb3c833..70b26534efcf499f5db8ef0ccfe1c63601d8ac44 100644 (file)
@@ -7,6 +7,7 @@
 
 define Profile/BR6104K
        NAME:=Edimax BR-6104K (Unofficial)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104K/Description
@@ -15,7 +16,7 @@ endef
 
 define Profile/BR6104KP
        NAME:=Edimax BR-6104KP (Unofficial)
-       PACKAGES:=kmod-usb-core kmod-usb-adm5120
+       PACKAGES:=-hostapd-mini kmod-usb-core kmod-usb-adm5120
 endef
 
 define Profile/BR6104KP/Description
@@ -24,6 +25,7 @@ endef
 
 define Profile/BR6104WG
        NAME:=Edimax BR-6104Wg (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6104WG/Description
@@ -32,6 +34,7 @@ endef
 
 define Profile/BR6114WG
        NAME:=Edimax BR-6114WG (Unofficial, No WiFi)
+       PACKAGES:=-hostapd-mini
 endef
 
 define Profile/BR6114WG/Description
index fe32e86e4453cd3489a7bf3e18cbf1709f499fbb..4aae711e228a752156ef6f940d85953df5d42ae6 100644 (file)
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 define Target/Description
        Build firmware images for Atheros AR71xx based boards
index 339940545cb672bec86959a2050500c709b1c0fe..4d7c316cecadc1bd65fc1eaf43b07f68964cb7cd 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.8
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += kmod-madwifi gpioctl
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi gpioctl
 
 define Target/Description
        Build firmware images for Atheros SoC boards
index 113f5520da4a5c18a205119543d4c4a49035f5e5..ed31eb70d9912b2a8dd9f7087adab74035329fe5 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FEATURES:=jffs2 usb pci
 LINUX_VERSION:=2.6.27.10
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += yamonenv
+DEFAULT_PACKAGES += hostapd-mini yamonenv
 
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
index 642f0e21d5beb8777cc8ef3bbb135d5dbaf866d8..ee32ddb13f5f462edc1c09e3c3b6f6d744fd0e79 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,7 +9,7 @@ define Profile/InternetBox
   NAME:=T-Mobile "InternetBox"
   PACKAGES:=kmod-madwifi \
                ldconfig ldd \
-               hostapd hostapd-utils ip tc wpa-supplicant wpa-cli
+               ip tc wpa-supplicant wpa-cli
 endef
 
 define Profile/InternetBox/Description
index 257f8d0630cf32711f52818c4f4084773b939c33..ddfae679df79364192b00f07139fcfeb79e7ed23 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2007 OpenWrt.org
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,8 +9,7 @@ define Profile/MeshCube
   NAME:=MeshCube MTX-1
   PACKAGES:=kmod-madwifi kmod-hostap kmod-hostap-pci kmod-net-prism54 \
        kmod-usb-core kmod-usb-ohci kmod-usb-storage kmod-fs-ext3 kmod-fs-vfat \
-       ldconfig ldd \
-       hostap-utils hostapd hostapd-utils ip tc wpa-supplicant wpa-cli
+       ldconfig ldd hostap-utils ip tc wpa-supplicant wpa-cli
 endef
 
 define Profile/MeshCube/Description
index d721abb13df56d9df42bbc9e9422e2b9900cf10f..c31f9a0db4fec9b06db8b5cf31b099638362e688 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/Atheros
   NAME:=Generic, Atheros WiFi
-  PACKAGES:=kmod-madwifi
+  PACKAGES:=hostapd-mini kmod-madwifi
 endef
 
 define Profile/Atheros/Description
index a3482364e8bfda1ffae72b7edfdd9ee38f68cf2a..2481e7f72dacbbed8592bad462e7dc7b86f136a2 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,7 +14,7 @@ FEATURES:=squashfs usb
 LINUX_VERSION:=2.6.25.20
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-switch kmod-diag
+DEFAULT_PACKAGES += hostapd-mini kmod-switch kmod-diag
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 2fcfacde9fa50cefb46f004c0109cb5935ed1235..513366dd724a125f70fb3a8e4fb2a937e9d8d028 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/None
   NAME:=No WiFi
-  PACKAGES:=
+  PACKAGES:=-hostapd-mini
 endef
 
 define Profile/None/Description
index c8862f030e204c13dbfa912ae8c676e54909d98d..eecfd9bcff5f923be7280030c6bcd1b2acb9f608 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -14,6 +14,8 @@ LINUX_VERSION:=2.6.27.10
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        currently supports BCM6348 and BCM6358 based devices.
index c05f709b584eed5a3070746075f8014e8aca7854..e590eee09218a51cceca672c8ddba427d1372449 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2007 OpenWrt.org
+#
+# Copyright (C) 2007-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,7 +15,7 @@ LINUX_VERSION:=2.6.26.8
 #LINUX_VERSION:=2.6.27.10
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES+=uboot-ifxmips
+DEFAULT_PACKAGES+=uboot-ifxmips hostapd-mini
 
 define Target/Description
        Build firmware images for Infineon Mips Controllers
index 5bfea2f7bf0af9f314bc7eb8f9c9b3ee529f2d9a..18c5c0cd976c5f3da2c41c2cdefd47e599bf1918 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/None
   NAME:=Generic, No WiFi
-  PACKAGES:=
+  PACKAGES:=-hostapd-mini
 endef
 
 define Profile/None/Description
index 17e48a549577fb138df313bc18b5e71cff5228f5..596710fa30f9a0e41f4797aa7e51948ad4cab0ac 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/NSLU2
   NAME:=Linksys NSLU2
-  PACKAGES:=kmod-scsi-core \
+  PACKAGES:=-hostapd-mini kmod-scsi-core \
        kmod-usb-core kmod-usb-ohci kmod-usb2 kmod-usb-storage \
        kmod-fs-ext2 kmod-fs-ext3
 endef
index 9306f79584b6a534bc1b7ed876f73761e3f60bd0..2ef0784c8543b4fcac179636824ade14cb36d67c 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -7,7 +7,7 @@
 
 define Profile/USR8200
   NAME:=USRobotics USR8200
-  PACKAGES:=kmod-scsi-core \
+  PACKAGES:=-hostapd-mini kmod-scsi-core \
        kmod-usb-core kmod-usb-uhci kmod-usb2 kmod-usb-storage \
        kmod-fs-ext2 kmod-fs-ext3 \
        kmod-ieee1394 kmod-ohci1394 kmod-sbp2
index 21fd5d4696522458c27f8cb546def4aa197179ee..e89cfc4f2340e14e25788eca1f551239724ac443 100644 (file)
@@ -1,5 +1,7 @@
 BOARDNAME:=Generic
 
+DEFAULT_PACKAGES+= hostapd-mini
+
 define Target/Description
        Build firmware images for ixp4xx based boards that boot from internal flash
        (e.g : Linksys NSLU2, ...)
index af5469e6feee263c1d23f379a95595bf3ea5840b..e35b81c7f1fa21b23409452dc0138b875371a329 100644 (file)
@@ -14,6 +14,6 @@ FEATURES:=jffs2 pci tgz
 LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += kmod-madwifi
+DEFAULT_PACKAGES += hostapd-mini kmod-madwifi
 
 $(eval $(call BuildTarget))
index 86265c38a1a01751408ec6a43b7c6459af8152ca..55600f910ef7bc6d3db1b9cd8c86666bbd656fd3 100644 (file)
@@ -1,5 +1,5 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
+#
+# Copyright (C) 2006-2008 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,6 +15,8 @@ LINUX_VERSION:=2.6.24.7
 
 include $(INCLUDE_DIR)/target.mk
 
+DEFAULT_PACKAGES += hostapd-mini
+
 define Target/Description
         Build firmware images for RDC321x based routers
         (e.g. Airlink101 AR525W, Linksys WRT54GR, Sitecom WL-153)