package/modules: package isp116x-hcd driver
authorGabor Juhos <juhosg@openwrt.org>
Fri, 16 Apr 2010 18:40:15 +0000 (18:40 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 16 Apr 2010 18:40:15 +0000 (18:40 +0000)
Cc: backfire@openwrt.org
SVN-Revision: 20934

package/kernel/modules/usb.mk

index c962e340ed12e8ac69e6112db1dffd733be2cd71..a5244d6d33a655ece20dc1faa5533e0806bea387 100644 (file)
@@ -158,6 +158,24 @@ endef
 $(eval $(call KernelPackage,usb-octeon))
 
 
+define KernelPackage/usb-isp116x-hcd
+$(call KernelPackage/usb/Depends,@TARGET_ppc40x)
+  TITLE:=Support for the ISP116x USB Host Controller
+  KCONFIG:= \
+       CONFIG_USB_ISP116X_HCD \
+       CONFIG_USB_ISP116X_HCD_OF=y \
+       CONFIG_USB_ISP116X_HCD_PLATFORM=n
+  FILES:=$(LINUX_DIR)/drivers/usb/host/isp116x-hcd.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,50,isp116x-hcd)
+endef
+
+define KernelPackage/usb-isp116x-hcd/description
+  Kernel support for the ISP116X USB Host Controller
+endef
+
+$(eval $(call KernelPackage,usb-isp116x-hcd))
+
+
 define KernelPackage/usb2
 $(call KernelPackage/usb/Depends,)
   TITLE:=Support for USB2 controllers
@@ -764,7 +782,7 @@ $(eval $(call KernelPackage,usb-net-cdc-ether))
 define KernelPackage/usb-net-rndis
 $(call KernelPackage/usb-net/Depends,@LINUX_2_6 +kmod-usb-net-cdc-ether)
   TITLE:=Support for RNDIS connections
-  KCONFIG:=CONFIG_USB_NET_RNDIS_HOST 
+  KCONFIG:=CONFIG_USB_NET_RNDIS_HOST
   FILES:= $(LINUX_DIR)/drivers/$(USBNET_DIR)/rndis_host.$(LINUX_KMOD_SUFFIX)
   AUTOLOAD:=$(call AutoLoad,62,rndis_host)
 endef