ubifs: when creating ubi(fs) images profile originated arguments have priority
authorLuka Perkov <luka@openwrt.org>
Sun, 13 Oct 2013 03:35:15 +0000 (03:35 +0000)
committerLuka Perkov <luka@openwrt.org>
Sun, 13 Oct 2013 03:35:15 +0000 (03:35 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38381

include/image.mk

index 67cfa4b677c2de74ee311b8575e0de7affda2feb..c79d82353810b38685df95be74b0a2793505f106 100644 (file)
@@ -121,9 +121,12 @@ endif
 ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
     define Image/mkfs/ubifs
 
-        ifdef UBIFS_OPTS
+        ifneq ($($(PROFILE)_UBIFS_OPTS)$(UBIFS_OPTS),)
                $(STAGING_DIR_HOST)/bin/mkfs.ubifs \
-                       $(UBIFS_OPTS) \
+                       $(if $($(PROFILE)_UBIFS_OPTS), \
+                               $(shell echo $($(PROFILE)_UBIFS_OPTS)), \
+                               $(shell echo $(UBIFS_OPTS)), \
+                       ) \
                        $(if $(CONFIG_TARGET_UBIFS_FREE_SPACE_FIXUP),--space-fixup) \
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_NONE),--force-compr=none) \
                        $(if $(CONFIG_TARGET_UBIFS_COMPRESSION_LZO),--force-compr=lzo) \
@@ -134,11 +137,14 @@ ifneq ($(CONFIG_TARGET_ROOTFS_UBIFS),)
         endif
        $(call Image/Build,ubifs)
 
-        ifdef UBI_OPTS
+        ifneq ($($(PROFILE)_UBI_OPTS)$(UBI_OPTS),)
                $(CP) ./ubinize.cfg $(KDIR)
                ( cd $(KDIR); \
                $(STAGING_DIR_HOST)/bin/ubinize \
-                       $(UBI_OPTS) \
+                       $(if $($(PROFILE)_UBI_OPTS), \
+                               $(shell echo $($(PROFILE)_UBI_OPTS)), \
+                               $(shell echo $(UBI_OPTS)), \
+                       ) \
                        -o $(KDIR)/root.ubi \
                        ubinize.cfg \
                )