sort entries in images md5sums files
authorNicolas Thill <nico@openwrt.org>
Wed, 10 Mar 2010 04:03:37 +0000 (04:03 +0000)
committerNicolas Thill <nico@openwrt.org>
Wed, 10 Mar 2010 04:03:37 +0000 (04:03 +0000)
SVN-Revision: 20116

include/image.mk

index 6c0c91ca1f9fa57303abf6eb983f8145e9a1c998..47871f9541aa1bd475a195555ccdf990e28345ac 100644 (file)
@@ -104,7 +104,7 @@ endif
 
 define Image/Checksum
        ( cd ${BIN_DIR} ; \
-               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | xargs \
+               $(FIND) -maxdepth 1 -type f \! -name 'md5sums'  -printf "%P\n" | sort | xargs \
                md5sum --binary > md5sums \
        )
 endef