prereq-build: add additional git detection
authorChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Thu, 9 Jun 2022 12:13:09 +0000 (14:13 +0200)
committerChristian 'Ansuel' Marangi <ansuelsmth@gmail.com>
Thu, 9 Jun 2022 13:30:33 +0000 (15:30 +0200)
With some OS (Guix) the git submodule command is wrapped in
a script. Current logic parse the git submodule script directly.
If it's wrapped the prereq check wrongly fails while 'git submodule
--recursive' is actually available.
Add an additional check that try to directly use the 'git submodule'
command to check if the prereq is satisfied.

Fixes: #9986
Reported-by: Attila Lendvai <attila@lendvai.name>
Suggested-by: Attila Lendvai <attila@lendvai.name>
Signed-off-by: Christian 'Ansuel' Marangi <ansuelsmth@gmail.com>
include/prereq-build.mk

index e1918f002787be0abae4953cfedc0cc327122ff7..4a8c2b063a8a4c64df52a642ae689afbcc668f2d 100644 (file)
@@ -177,7 +177,8 @@ $(eval $(call TestHostCommand,python3-distutils, \
        $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
        $(STAGING_DIR_HOST)/bin/python3 -c 'import distutils'))
 
 $(eval $(call SetupHostCommand,git,Please install Git (git-core) >= 1.7.12.2, \
-       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule))
+       git --exec-path | xargs -I % -- grep -q -- --recursive %/git-submodule, \
+       git submodule --help | grep -- --recursive))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))
 
 $(eval $(call SetupHostCommand,file,Please install the 'file' package, \
        file --version 2>&1 | grep file))