ath79: fix build warning
authorMathias Kresin <dev@kresin.me>
Sun, 7 Oct 2018 13:33:35 +0000 (15:33 +0200)
committerMathias Kresin <dev@kresin.me>
Sun, 7 Oct 2018 13:44:19 +0000 (15:44 +0200)
The image build code for the Ubiquiti Nanostation AC series adds the
factory image as to be build image. The same is already done by an
included recipe which results into an expanded IMAGE variable of:

  IMAGES = sysupgrade.bin factory.bin factory.bin

The build system doesn't like these duplicates and issues the following
warning:

  Makefile:82: warning: overriding recipe for target...

Get remove the duplicate factory image to get rid of the warning.

Fixes: 5736af8024be ("ath79: Add support for Ubiquiti NanoStation AC loco")
       fa3c2676ab0c ("ath79: Add support for Ubiquiti Nanostation AC")

Signed-off-by: Mathias Kresin <dev@kresin.me>
target/linux/ath79/image/generic-ubnt.mk

index 91cd5fc681c484c9435ae853a8346de14df99589..8cdd5a2d2fddec1c0bfb520768bd5c247f85c7c5 100644 (file)
@@ -89,7 +89,6 @@ define Device/ubnt_nanostation-ac
   DEVICE_TITLE := Ubiquiti Nanostation AC
   DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
   IMAGE_SIZE := 15744k
-  IMAGES += factory.bin
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
 TARGET_DEVICES += ubnt_nanostation-ac
@@ -99,7 +98,6 @@ define Device/ubnt_nanostation-ac-loco
   DEVICE_TITLE := Ubiquiti Nanostation AC loco
   DEVICE_PACKAGES += kmod-ath10k ath10k-firmware-qca988x
   IMAGE_SIZE := 15744k
-  IMAGES += factory.bin
   IMAGE/factory.bin := $$(IMAGE/sysupgrade.bin) | mkubntimage-split
 endef
 TARGET_DEVICES += ubnt_nanostation-ac-loco