disable libtool fixups in trunk globally
authorMirko Vogt <mirko@openwrt.org>
Sat, 4 Dec 2010 00:11:09 +0000 (00:11 +0000)
committerMirko Vogt <mirko@openwrt.org>
Sat, 4 Dec 2010 00:11:09 +0000 (00:11 +0000)
SVN-Revision: 24234

include/autotools.mk

index 1ddb49b7d4f07f1588acd15ba965f3f395f2cc92..7e251ead533dc995aa479f63bfccb4e8edc5732f 100644 (file)
@@ -49,17 +49,18 @@ define remove_version_check
        fi
 endef
 
-ifneq ($(filter libtool,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool remove_version_check
-  Hooks/Configure/Post += update_libtool
-  Hooks/InstallDev/Post += libtool_fixup_libdir
-endif
-
-ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
-  PKG_BUILD_DEPENDS += libtool
-  Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
-  Hooks/Configure/Post += update_libtool_ucxx
-  Hooks/InstallDev/Post += libtool_fixup_libdir
-endif
+# XXX the libtool fixups got deactivated in the course of switching to libtool2 in trunk XXX
+# ifneq ($(filter libtool,$(PKG_FIXUP)),)
+#   PKG_BUILD_DEPENDS += libtool
+#   Hooks/Configure/Pre += update_libtool remove_version_check
+#   Hooks/Configure/Post += update_libtool
+#   Hooks/InstallDev/Post += libtool_fixup_libdir
+# endif
+# 
+# ifneq ($(filter libtool-ucxx,$(PKG_FIXUP)),)
+#   PKG_BUILD_DEPENDS += libtool
+#   Hooks/Configure/Pre += update_libtool_ucxx remove_version_check
+#   Hooks/Configure/Post += update_libtool_ucxx
+#   Hooks/InstallDev/Post += libtool_fixup_libdir
+# endif