toolchain/gcc: Add GCC 10.1.0 config
authorSyrone Wong <wong.syrone@gmail.com>
Tue, 7 Jul 2020 22:41:21 +0000 (06:41 +0800)
committerPetr Štetiar <ynezz@true.cz>
Sat, 11 Jul 2020 11:33:28 +0000 (13:33 +0200)
Add needed config changes and tarball hash for new GCC version.

Signed-off-by: Syrone Wong <wong.syrone@gmail.com>
[added missing commit description]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
toolchain/gcc/Config.in
toolchain/gcc/Config.version
toolchain/gcc/common.mk

index 4b2ba7aaaeae39766c9df24947890c5852299efd..1aadae68398fd93ddbecb36c2b97490f4d72901a 100644 (file)
@@ -19,6 +19,9 @@ choice
 
        config GCC_USE_VERSION_9
                bool "gcc 9.x"
+
+       config GCC_USE_VERSION_10
+               bool "gcc 10.x"
 endchoice
 
 config GCC_USE_GRAPHITE
index 6fbc6d980468230fbc465d51109e8f383f9c4f79..ccc7b273facb4c6296c6f450fb68258b84ef061a 100644 (file)
@@ -10,11 +10,16 @@ config GCC_VERSION_9
        default y if GCC_USE_VERSION_9
        bool
 
+config GCC_VERSION_10
+       default y if GCC_USE_VERSION_10
+       bool
+
 config GCC_VERSION
        string
        default "5.5.0"         if GCC_VERSION_5
        default "7.5.0"         if GCC_VERSION_7
        default "9.3.0"         if GCC_VERSION_9
+       default "10.1.0"        if GCC_VERSION_10
        default "8.4.0"
 
 config GCC_USE_IREMAP
index ec3ea8fff1d92ab9edde78df81073b280d3b303f..eb0ddbf2d9c214b2b3653c0fdd1adba22c0acd84 100644 (file)
@@ -44,6 +44,10 @@ ifeq ($(PKG_VERSION),9.3.0)
   PKG_HASH:=71e197867611f6054aa1119b13a0c0abac12834765fe2d81f35ac57f84f742d1
 endif
 
+ifeq ($(PKG_VERSION),10.1.0)
+  PKG_HASH:=b6898a23844b656f1b68691c5c012036c2e694ac4b53a8918d4712ad876e7ea2
+endif
+
 PATCH_DIR=../patches/$(GCC_VERSION)
 
 BUGURL=http://bugs.openwrt.org/