ramips: add SD-Card support for Linkit Smart 7688
authorIvan Hörler <i.hoerler@me.com>
Sat, 14 Sep 2019 15:25:04 +0000 (17:25 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Sun, 15 Sep 2019 18:34:09 +0000 (20:34 +0200)
The Linkit Smart 7688 has a SD-Card reader that does not work with the official build of openwrt. Adding kmod-sdhci-mt7620 makes it working.

Signed-off-by: Ivan Hörler <i.hoerler@me.com>
target/linux/ramips/image/mt76x8.mk

index a602d9df21036916128cfa5d6c86f66705e90ece..76d4c635d43e235630e510e707062bc7b5bd6dd1 100644 (file)
@@ -135,7 +135,7 @@ define Device/mediatek_linkit-smart-7688
   IMAGE_SIZE := 32448k
   DEVICE_VENDOR := MediaTek
   DEVICE_MODEL := LinkIt Smart 7688
-  DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci uboot-envtools
+  DEVICE_PACKAGES:= kmod-usb2 kmod-usb-ohci uboot-envtools kmod-sdhci-mt7620
   SUPPORTED_DEVICES += linkits7688 linkits7688d
 endef
 TARGET_DEVICES += mediatek_linkit-smart-7688