kernel: makefiles: make use of new var KERNEL_PATCHVER
authorFelix Fietkau <nbd@openwrt.org>
Fri, 24 Oct 2014 19:34:02 +0000 (19:34 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 24 Oct 2014 19:34:02 +0000 (19:34 +0000)
replace all occurences of LINUX_VERSION with the cleaner
approach. future kernel upgrades must mostly touch only
one file. the only platform left is netlogic, because it
uses a intermediate kernel 3.14.16

Signed-off-by: Bastian Bittorf <bittorf@bluebottle.com>
SVN-Revision: 43047

49 files changed:
target/linux/adm5120/Makefile
target/linux/adm8668/Makefile
target/linux/amazon/Makefile
target/linux/ar7/Makefile
target/linux/ar71xx/Makefile
target/linux/at91/Makefile
target/linux/atheros/Makefile
target/linux/au1000/Makefile
target/linux/avr32/Makefile
target/linux/bcm53xx/Makefile
target/linux/brcm2708/Makefile
target/linux/brcm47xx/Makefile
target/linux/brcm63xx/Makefile
target/linux/cns21xx/Makefile
target/linux/cns3xxx/Makefile
target/linux/cobalt/Makefile
target/linux/ep93xx/Makefile
target/linux/gemini/Makefile
target/linux/imx6/Makefile
target/linux/iop32x/Makefile
target/linux/ipq806x/Makefile
target/linux/ixp4xx/Makefile
target/linux/kirkwood/Makefile
target/linux/lantiq/Makefile
target/linux/malta/Makefile
target/linux/mcs814x/Makefile
target/linux/mpc52xx/Makefile
target/linux/mpc83xx/Makefile
target/linux/mpc85xx/Makefile
target/linux/mvebu/Makefile
target/linux/mxs/Makefile
target/linux/octeon/Makefile
target/linux/omap/Makefile
target/linux/omap24xx/Makefile
target/linux/orion/Makefile
target/linux/ppc40x/Makefile
target/linux/ppc44x/Makefile
target/linux/pxa/Makefile
target/linux/ramips/Makefile
target/linux/rb532/Makefile
target/linux/realview/Makefile
target/linux/sibyte/Makefile
target/linux/sparc/Makefile
target/linux/sunxi/Makefile
target/linux/uml/Makefile
target/linux/x86/Makefile
target/linux/x86/ep80579/target.mk
target/linux/x86_64/Makefile
target/linux/xburst/Makefile

index 2500f90e773674c58a60a6fac540862cf93b268f..e58122db0767960e5e17779bd479be26974e9e7b 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
 
 BOARD:=adm5120
 BOARDNAME:=Infineon/ADMtek ADM5120
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=3.8
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
 SUBTARGETS:=router_le router_be rb1xx
 INITRAMFS_EXTRA_FILES:=
 
index de3b9e787823dafe91194bbca39bd44e336cfc57..2220bbd12057269d9028654221e6cba892131e21 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Infineon WildPass ADM8668
 FEATURES:=squashfs usb pci
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 FEATURES:=squashfs usb pci
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index d2d4e8d6736b843c9d0e7147bb755792c221e476..9553da098c7ee549d84fdfba818b5b1a06dc9ccc 100644 (file)
@@ -10,7 +10,7 @@ ARCH:=mips
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs broken
 BOARD:=amazon
 BOARDNAME:=Infineon Amazon
 FEATURES:=squashfs broken
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 3f40e57837a703f0e2423fa3101d681a8839ed53..0f6377fdaad49c882e9f6f5b4e38f6e3beffba79 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs atm low_mem
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 SUBTARGETS:=generic ac49x
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 1b400745d1b5c4bc777e3342ebccb3a687154267..74bc361faf75b3e671dde5fecb90ef35b6ad0345 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=mips16
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand mikrotik
 
 CPU_TYPE=34kc
 SUBTARGETS:=generic nand mikrotik
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c7e67fec010247dc345c233747160e9db7792a61..27ee330026f925f2c6b09999a1d98f448cd52e98 100644 (file)
@@ -13,7 +13,7 @@ BOARDNAME:=Atmel AT91
 FEATURES:=squashfs targz ext2 usb
 SUBTARGETS:=legacy sama5d3
 
 FEATURES:=squashfs targz ext2 usb
 SUBTARGETS:=legacy sama5d3
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 9ebbd34cb4839b40d44970a365867cb4baa975d9..3983ff7ad38bbdc0b95dd86fd3beb26bf1d3fed0 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs low_mem
 
 BOARDNAME:=Atheros AR231x/AR5312
 FEATURES:=squashfs low_mem
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 9a2e4f5fae1d29f87ad95bb1565a32912259d00e..cb08fb5f28eced463601cf2fc8243a01fcd4f8d2 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index cd8bd5e60d59617effa8bd97286d6b4bcbf129f5..b6802a466c83f43e944abca044c1a1df5248ea8b 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 69f30f84ec99e220147dbebc10eb4cd51f5505db..f47dae81803311e7ac164bbe558b0b726cf221aa 100644 (file)
@@ -14,7 +14,7 @@ MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c8a55369349ba45ffc70908a7f24bb0dd906caa1..c6d72bcbdd4259a093e5a974e053b4ba11cc3283 100644 (file)
@@ -15,7 +15,7 @@ MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
 CPU_TYPE:=arm1176jzf-s
 CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
index c15ba1c682520ba03a1f340479ca04efd4fd3696..010013307d8b30a383e2b8f20c85e753c5aa5a53 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs usb
 SUBTARGETS:=generic mips74k legacy
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
 SUBTARGETS:=generic mips74k legacy
 MAINTAINER:=Hauke Mehrtens <hauke@hauke-m.de>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c7fdfe60be5dc6acec9e102fe5c18887f238b8da..1ff2eb05524c15bea1bf87010da3c796dbb4e559 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia usbgadget
 BOARDNAME:=Broadcom BCM63xx
 SUBTARGETS:=generic smp
 FEATURES:=squashfs usb atm pci pcmcia usbgadget
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index a183a21b865f2586e53dd44266421ab5549ddaa5..866030a9d0713593c1c9f5ed694d509725a2fb25 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Cavium Networks Econa CNS21xx
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
 FEATURES:=squashfs
 CPU_TYPE:=fa526
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index dd5349cd6f6264f74cf8bd804aaacb744c7e4f31..27ed12f2f78260550a0228a25c71daafdb0916f1 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 527d36dd94bc51acb73fd09eba77b8c10f76b55c..5f0adc288abd969389240995c5ad383a6873778d 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE := 5k
 CPU_CFLAGS_5k := -march=r5000
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 CPU_CFLAGS_5k := -march=r5000
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index ad7fb31bd30716d47d052c3ec5f8e8f3eeef8098..7e7422b192b01490b190a068c09f1bdd9f4cfe01 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 targz usb display sound
 CPU_TYPE:=arm920t
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 CPU_TYPE:=arm920t
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=3.8
 
 DEVICE_TYPE:=developerboard
 
 
 DEVICE_TYPE:=developerboard
 
index 45ae97ef9189ad631f920ed0b880e523c3f20c6e..7eb751ec703c553963c1a6b06c27b1a93ba91bc9 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs pci
 CPU_TYPE:=fa526
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CPU_TYPE:=fa526
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 KERNELNAME:=zImage
 
 
 KERNELNAME:=zImage
 
index c29187cb35131bf43fbe8d826b760a5047f7c22c..a9da7bf99a2e83c168b1bc360df6f4091ba082ff 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
 CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 02037d9837a6148b01badc2281449e53eb97c40e..1159c74b05fec2967f1c197655790052956aa601 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Intel IOP32x
 FEATURES:=squashfs broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=squashfs broken
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 55a0d72f7ddd04ba0b669ec628d71302e68975d3..875bb9cee917c8d76bc96389453a53cc5aa7a2d7 100644 (file)
@@ -9,7 +9,7 @@ FEATURES:=squashfs
 CPU_TYPE:=cortex-a7
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 CPU_TYPE:=cortex-a7
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 KERNELNAME:=Image dtbs
 
 
 KERNELNAME:=Image dtbs
 
index 2b249dc85591901da599b965e0c71ef6b8ce05c5..780ca9653dde22f0eb7ce33318e19b5736acae0b 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic harddisk
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 4b6d841de2f4a8cdc0fd474175f7f2bce64a0588..bf3c431a17fff23c62435e3c364bbf62aeabc30d 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz usb jffs2_nand nand ubifs
 CPU_TYPE:=xscale
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CPU_TYPE:=xscale
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index f5ba6bf4f498cd9df2a7c6a49b857c58792cb37b..99075dcbb1e0607757a301ba39c86a1b26816d1d 100644 (file)
@@ -12,7 +12,7 @@ FEATURES:=squashfs
 SUBTARGETS=xway xrx200
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 SUBTARGETS=xway xrx200
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 CPU_TYPE:=mips32r2
 
 
 CPU_TYPE:=mips32r2
 
index e5b16b2bdcd5283ea1394f2773fb643979fe76cb..77967540035a6aef95ffbefd350aa5a026554331 100644 (file)
@@ -12,7 +12,7 @@ SUBTARGETS:=le be le64 be64
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 INITRAMFS_EXTRA_FILES:=
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 DEVICE_TYPE:=developerboard
 
 
 DEVICE_TYPE:=developerboard
 
index 25c778afa6ab71c89bad3883327427b6df18ad5c..091f74dd08c5834b892082d325d31a796be8b8e8 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=usb squashfs
 CPU_TYPE:=arm926ej-s
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 CPU_TYPE:=arm926ej-s
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 DEVICE_TYPE:=other
 
 
 DEVICE_TYPE:=other
 
index 56f655a31e88b87b267b748dcc3dbe5cc2a96e00..aa3c5a72ccf40f5bbaeb7070ba8f211e734319cf 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Freescale MPC52xx
 CPU_TYPE:=603e
 FEATURES:=targz ext4
 
 CPU_TYPE:=603e
 FEATURES:=targz ext4
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=3.8
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 806b8f6e4e53e46998140f4a7221a43d8b304516..c5ab1e2d55a5d2bdc29a7e028b26dc0fa871bb1f 100644 (file)
@@ -13,7 +13,7 @@ CPU_TYPE:=603e
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=squashfs targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.8.13
+KERNEL_PATCHVER:=3.8
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 37669684db1c5005a7d5d2846ffce7b3233ab8a6..dba0361ee45a291e60bb9feea44192759f53ac1b 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=spe_fpu squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 SUBTARGETS=generic p1020
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index dc61e7c2c170894956c5ac32db8b7d7ab82f2602..630a3306082fc92d4f62ef21ba63b5fca4528f73 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 9f950959b841993c37a0650e9abdf070966682ed..7e5183fb6d9f5ce7c662a4608b4b6b5198472790 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=ext4 rtc usb gpio
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 CPU_TYPE:=arm926ej-s
 
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 KERNELNAME:=zImage dtbs
 
 define Target/Description
 KERNELNAME:=zImage dtbs
 
 define Target/Description
index 507938fe7be1060d4eb07c53df817f6a2541b98d..e15aad81d29736c1720bbc58ca94c7103066f440 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=octeon
 CPU_CFLAGS_octeon:=-march=octeon -mabi=64
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 CPU_CFLAGS_octeon:=-march=octeon -mabi=64
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 3ebfccddc32eab89a610de676d303b2a1f026534..03a2c244e49147860ff755e40d87443f19b9ba04 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=usb usbgadget ext4 targz fpu audio display nand ubifs
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
 CPU_TYPE:=cortex-a9
 CPU_SUBTYPE:=vfpv3
 
-LINUX_VERSION:=3.13.7
+KERNEL_PATCHVER:=3.13
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
index 40ad342bed50fc9dced584b3c6e3082a713810b4..af82384730a77521769b8a3879ba13f96aba7812 100644 (file)
@@ -13,7 +13,7 @@ MAINTAINER:=Michael Buesch <m@bues.ch>
 FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
 CPU_TYPE:=arm1136j-s
 
 FEATURES:=targz squashfs jffs2_nand usb usbgadget display gpio audio broken
 CPU_TYPE:=arm1136j-s
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 define Target/Description
        TI OMAP-24xx
 
 define Target/Description
        TI OMAP-24xx
index ec40a00d18dec2c9cfce7f92d7e714d480c7e423..6717540d6d442c55db461e716efcfce09ed7f7ff 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell Orion
 SUBTARGETS:=generic harddisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 SUBTARGETS:=generic harddisk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 00e8d4322cd8d850e5205d46a74f7dca230f7123..fee261e4b1726a2bf912c9a093cd4f5c107e8372 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CPU_TYPE:=405
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 5c2e15da2abf7e41f650b552e038d64f8e6ccfab..c36675cc05663c049670dd497b91f97bbc7e03fd 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs broken
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CPU_TYPE:=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index c61231daf7a9adc19991a46358981b045fd9ad91..2aed3d9caf28ddcf9c31d4f9478dafecf8b46798 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Marvell/Intel PXA2xx
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=squashfs
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 008e5aa06753acf945d44b83d45b123be1f0b6ac..cf1b9e831168a45d01b3e128cf5c87502fbf542e 100644 (file)
@@ -13,7 +13,7 @@ SUBTARGETS:=rt305x mt7620a mt7620n mt7621 rt3883 rt288x
 FEATURES:=squashfs gpio
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
 FEATURES:=squashfs gpio
 MAINTAINER:=John Crispin <blogic@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += \
index e07afc138c588d963a30054b2730af95c890dc1d..0a6bd712d08e1499276b4c4c41b605f1a8aababa 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz
 
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=pci targz
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-ath5k kmod-input-rb532
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-ath5k kmod-input-rb532
index 80892075b0999366e4332975f93b1c4bdbf91c57..065c170ae47b5e5316d3532d1612e9bb42c21e99 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=mpcore
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 CPU_SUBTYPE:=vfp
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 DEVICE_TYPE:=developerboard
 
 
 DEVICE_TYPE:=developerboard
 
index 2370cac25dc1fc8f058ec287f1f4e54cc9c1a664..a98b170f59f49aecdae5a6fee5f427a21f03ae5a 100644 (file)
@@ -14,7 +14,7 @@ CPU_TYPE:=sb1
 CPU_CFLAGS_sb1:=-march=sb1
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 CPU_CFLAGS_sb1:=-march=sb1
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 0fee7c17ebc428e568071780f3e792f90f8edfd3..13a5a05987a7dad050dca318c25e1c05db7dbc12 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=sparc
 BOARDNAME:=Sun UltraSPARC
 FEATURES+=fpu tgz ext4 squashfs broken
 
 BOARDNAME:=Sun UltraSPARC
 FEATURES+=fpu tgz ext4 squashfs broken
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 include $(INCLUDE_DIR)/target.mk
index e96f0815b4f6ae12bcbfdbc9c901024275d040c4..0deb2d8f2766f959ad0157bb165812d3829cb0db 100644 (file)
@@ -15,7 +15,7 @@ CPU_TYPE:=cortex-a8
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
 CPU_SUBTYPE:=vfpv3
 MAINTAINER:=Zoltan HERPAI <wigyori@uid0.hu>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 KERNELNAME:=zImage dtbs
 DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi kmod-wdt-sunxi
 
 KERNELNAME:=zImage dtbs
 DEFAULT_PACKAGES += uboot-envtools uboot-sunxi kmod-eeprom-sunxi kmod-wdt-sunxi
 
index 35290da28e1a80f6a1939c8915ff39e654e3678c..eb4fed11e9d28c289bcb50041c772a4712af43a2 100644 (file)
@@ -23,7 +23,7 @@ BOARDNAME:=User Mode Linux
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
 FEATURES:=ext4 audio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 include $(INCLUDE_DIR)/target.mk
 
 
 include $(INCLUDE_DIR)/target.mk
 
index 32eafdfc0a50afacf760b63aa939c24f532536b0..13f15c082634c369f4f0f9e029e210eb6f7abc86 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs ext4 vdi vmdk pcmcia targz
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
           rdc
 
 SUBTARGETS=generic olpc xen_domu ep80579 net5501 kvm_guest geos alix2 thincan \
           rdc
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 KERNELNAME:=bzImage
 
 
 KERNELNAME:=bzImage
 
index 4fe35e0440328e04a239f24b554146b9f5baa8a6..f4bd20a0f15614722e5a9814dcd361eedd052537 100644 (file)
@@ -1,5 +1,5 @@
 BOARDNAME:=Intel EP80579
 BOARDNAME:=Intel EP80579
-LINUX_VERSION:=3.3.8
+KERNEL_PATCHVER:=3.3
 DEFAULT_PACKAGES += kmod-ep80579-can kmod-ep80579-eth kmod-ep80579-misc \
                        kmod-usb-core kmod-usb2 kmod-usb-hid kmod-usb-uhci
 
 DEFAULT_PACKAGES += kmod-ep80579-can kmod-ep80579-eth kmod-ep80579-misc \
                        kmod-usb-core kmod-usb2 kmod-usb-hid kmod-usb-uhci
 
index 73898ec62a4aa37b321ab1263b272b96ac501c81..ca0a05a38be60fa4f1f4427a538b6916db001fbf 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=x86_64
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
 FEATURES:=ext4 vdi vmdk targz
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.14.18
+KERNEL_PATCHVER:=3.14
 
 KERNELNAME:=bzImage
 
 
 KERNELNAME:=bzImage
 
index 92897393d69683a17592c28a60853ab3c11cd2b0..64ee7ec4ec978ba609aebb9fb1d75c32c856fcfd 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=targz nand ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
 FEATURES:=targz nand ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.10.49
+KERNEL_PATCHVER:=3.10
 
 DEVICE_TYPE=other
 
 
 DEVICE_TYPE=other