kernel: add a dependency of kmod-r8169 on r8169-firmware
authorFelix Fietkau <nbd@openwrt.org>
Thu, 10 Apr 2014 14:43:33 +0000 (14:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 10 Apr 2014 14:43:33 +0000 (14:43 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 40448

package/kernel/linux/modules/netdevices.mk

index 98d8e306b7da0bcd8a0909b95771e787468610f2..a2892aed0c312b204d40e307a8c956b09f7d53dc 100644 (file)
@@ -353,7 +353,7 @@ $(eval $(call KernelPackage,8139cp))
 define KernelPackage/r8169
   SUBMENU:=$(NETWORK_DEVICES_MENU)
   TITLE:=RealTek RTL-8169 PCI Gigabit Ethernet Adapter kernel support
-  DEPENDS:=@PCI_SUPPORT +kmod-mii
+  DEPENDS:=@PCI_SUPPORT +kmod-mii +r8169-firmware
   KCONFIG:=CONFIG_R8169 \
     CONFIG_R8169_NAPI=y \
     CONFIG_R8169_VLAN=n