layerscape: put u-boot and ucode images into image staging directory
authorJo-Philipp Wich <jo@mein.io>
Fri, 27 Jan 2017 15:06:31 +0000 (16:06 +0100)
committerJo-Philipp Wich <jo@mein.io>
Fri, 27 Jan 2017 15:53:31 +0000 (16:53 +0100)
Do not put the u-boot and ucode images into the kernel build directory as this
directory might get removed after kernel updates while the u-boot packages
InstallDev recipe is not getting re-executed because it is still considered
current, leading to image build failures later on due to missing images.

To ensure that built bootloader images persist over kernel version updates in
the buildroot, put them into the new STAGING_DIR_IMAGE directory.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
package/boot/uboot-layerscape-32b/Makefile
package/boot/uboot-layerscape/Makefile
package/firmware/fman-ucode/Makefile
package/firmware/rcw/Makefile
target/linux/layerscape/image/Makefile

index 852c83a929dec3105b013fb8729051985d1db9ab..cf56eedd30eb666ff87b867d899ab30f512678ea 100644 (file)
@@ -42,9 +42,10 @@ define Build/Compile
 endef
 
 define Build/InstallDev
-       $(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(KERNEL_BUILD_DIR)/ls1043ardb-32b-uboot.bin
-       $(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(KERNEL_BUILD_DIR)/ls1046ardb-32b-uboot.bin
-       $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin.swap $(KERNEL_BUILD_DIR)/ls1012ardb-32b-uboot.bin
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(CP) $(PKG_BUILD_DIR)/ls1043ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1043ardb-32b-uboot.bin
+       $(CP) $(PKG_BUILD_DIR)/ls1046ardb-uboot.bin $(STAGING_DIR_IMAGE)/ls1046ardb-32b-uboot.bin
+       $(CP) $(PKG_BUILD_DIR)/ls1012ardb-uboot.bin.swap $(STAGING_DIR_IMAGE)/ls1012ardb-32b-uboot.bin
 endef
 
 $(eval $(call BuildPackage,uboot-layerscape-32b))
index f0ab72653458c0b450f45d0bf7d667e7c33e8c32..ac3d7aba8620d6ccc7be230b65f640423d2d5e92 100644 (file)
@@ -49,7 +49,8 @@ UBOOT_TARGETS := \
        ls1012ardb
 
 define Build/InstallDev
-       $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(KERNEL_BUILD_DIR)/$(BUILD_VARIANT)-64b-uboot.bin
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(INSTALL_DATA) $(PKG_BUILD_DIR)/$(UBOOT_IMAGE) $(STAGING_DIR_IMAGE)/$(BUILD_VARIANT)-64b-uboot.bin
 endef
 
 define Package/u-boot/install/default
index 5a0238dee24cc9b5ce2b50e93bbec565fbae18b8..396750f804713f6037ff0f96349550f7a9c7b0aa 100644 (file)
@@ -72,7 +72,8 @@ define Build/Compile
 endef
 
 define Package/fman/install/default
-       $(CP) $(PKG_BUILD_DIR)/$(FMAN_CONFIG) $(KDIR)/$(1)-fman.bin
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(CP) $(PKG_BUILD_DIR)/$(FMAN_CONFIG) $(STAGING_DIR_IMAGE)/$(1)-fman.bin
 endef
 
 define Package/fman/install/template
index d832e6e5d70e16a6b74b175a2404ce1453b4268f..bae9c95b6cc4870598f94b65c105d2638ec074af 100644 (file)
@@ -81,7 +81,8 @@ define Build/Compile
 endef
 
 define Package/rcw/install/default
-       $(CP) $(PKG_BUILD_DIR)/$(RCW_CONFIG) $(KDIR)/$(1)-rcw.bin
+       $(INSTALL_DIR) $(STAGING_DIR_IMAGE)
+       $(CP) $(PKG_BUILD_DIR)/$(RCW_CONFIG) $(STAGING_DIR_IMAGE)/$(1)-rcw.bin
 endef
 
 define Package/rcw/install/template
index 341d5fbda0b8f7dfa3f62b08bebc9c0c77238cb3..107a3e6eed1b625e7844c4354637d21a67d51a76 100644 (file)
@@ -9,15 +9,15 @@ include $(INCLUDE_DIR)/image.mk
 
 define Build/append-ls-rcw
        rm -f $@
-       dd if=$(KDIR)/$(1)-rcw.bin >> $@
+       dd if=$(STAGING_DIR_IMAGE)/$(1)-rcw.bin >> $@
 endef
 
 define Build/append-ls-uboot
-       dd if=$(KDIR)/$(1)-$(SUBTARGET)-uboot.bin >> $@
+       dd if=$(STAGING_DIR_IMAGE)/$(1)-$(SUBTARGET)-uboot.bin >> $@
 endef
 
 define Build/append-ls-fman
-       dd if=$(KDIR)/$(1)-fman.bin >> $@
+       dd if=$(STAGING_DIR_IMAGE)/$(1)-fman.bin >> $@
 endef
 
 define Build/append-ls-dtb