don't touch TAR_OPTIONS in host.mk
authorFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:13:40 +0000 (17:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Tue, 10 Oct 2006 17:13:40 +0000 (17:13 +0000)
SVN-Revision: 5024

openwrt/include/host.mk
openwrt/toolchain/kernel-headers/Makefile

index 93f86dce8aafbdc5a3a379455787a657188bc97d..9eee20fcfbe98013a18e57041bd765084c0dc9a2 100644 (file)
@@ -23,6 +23,6 @@ $(TOPDIR)/.host.mk: $(INCLUDE_DIR)/host.mk
                        -e 's/i[3-9]86/i386/'`" >> $@
        @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
        @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
                        -e 's/i[3-9]86/i386/'`" >> $@
        @echo "GNU_HOST_NAME:=`$(HOSTCC) -dumpmachine`" >> $@
        @if tar --version 2>&1 | grep 'GNU' >/dev/null; then \
-               echo "TAR_OPTIONS+=--wildcards" >> $@; \
+               echo "TAR_WILDCARDS:=--wildcards" >> $@; \
        fi
 
        fi
 
index 3e2cd2ae8678074d1956870660dd8aaf9814c14a..a893b8511c4690889a156cb18c19ff754987893a 100644 (file)
@@ -32,7 +32,7 @@ LINUX_KARCH:=$(shell echo $(ARCH) | sed -e 's/i[3-9]86/i386/' \
 
 define Build/Prepare
        mkdir -p $(TOOLCHAIN_BUILD_DIR)
 
 define Build/Prepare
        mkdir -p $(TOOLCHAIN_BUILD_DIR)
-       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
+       bzcat $(DL_DIR)/$(PKG_SOURCE) | tar $(TAR_WILDCARDS) -C $(TOOLCHAIN_BUILD_DIR) $(TAR_OPTIONS) - \
                linux-$(PKG_VERSION)/include \
                linux-$(PKG_VERSION)/Makefile \
                linux-$(PKG_VERSION)/Rules.make \
                linux-$(PKG_VERSION)/include \
                linux-$(PKG_VERSION)/Makefile \
                linux-$(PKG_VERSION)/Rules.make \