fix GNU_HOST_NAME for non-linux machines
authorFelix Fietkau <nbd@openwrt.org>
Wed, 27 Sep 2006 13:11:47 +0000 (13:11 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 27 Sep 2006 13:11:47 +0000 (13:11 +0000)
SVN-Revision: 4865

openwrt/rules.mk

index 3645b064f7b50b7e93a99f23fab45c7ab565e32a..768b4805595624487068621601ea7f56886c70a6 100644 (file)
@@ -76,7 +76,7 @@ HOST_ARCH:=$(shell $(HOSTCC) -dumpmachine | sed -e s'/-.*//' \
        -e 's/i[3-9]86/i386/' \
        )
 
-GNU_HOST_NAME:=$(HOST_ARCH)-pc-linux-gnu
+GNU_HOST_NAME:=$(shell $(HOSTCC) -dumpmachine)
 
 TARGET_CONFIGURE_OPTS:= \
   AR=$(TARGET_CROSS)ar \