build: Fix print without color
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Feb 2019 18:29:08 +0000 (19:29 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 17 Feb 2019 18:30:34 +0000 (19:30 +0100)
The original patch removed the printing completely, just remove the
color.

Fixes: eabc1ddc4541 ("build: Honour NO_COLOR in include/scan.mk")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
include/scan.mk

index 724dbfaf179f2bf343d36de38549c7b647a3dff5..d9cd4f7e8c30845a3de2725275e1188c694ed3a5 100644 (file)
@@ -25,7 +25,7 @@ ifeq ($(IS_TTY),1)
     endef
   else
     define progress
-       :;
+       printf "\r$(1)" >&2;
     endef
   endif
 else