kernel: bump 5.10 to 5.10.137
authorPetr Štetiar <ynezz@true.cz>
Mon, 22 Aug 2022 20:45:53 +0000 (22:45 +0200)
committerPetr Štetiar <ynezz@true.cz>
Tue, 23 Aug 2022 08:37:04 +0000 (10:37 +0200)
Removed following upstreamed patch:

 * bcm53xx: 081-next-ARM_dts_BCM53015-add-mr26.patch

All other patches automagically rebased.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
23 files changed:
include/kernel-5.10
target/linux/ath25/patches-5.10/140-redboot_boardconfig.patch
target/linux/ath25/patches-5.10/141-redboot_partition_scan.patch
target/linux/ath25/patches-5.10/142-redboot_various_erase_size_fix.patch
target/linux/bcm53xx/patches-5.10/033-v5.15-0008-ARM-dts-NSP-Add-DT-files-for-Meraki-MX64-series.patch
target/linux/bcm53xx/patches-5.10/033-v5.15-0009-ARM-dts-NSP-Add-DT-files-for-Meraki-MX65-series.patch
target/linux/bcm53xx/patches-5.10/081-next-ARM_dts_BCM53015-add-mr26.patch [deleted file]
target/linux/bcm63xx/patches-5.10/143-gpio-fix-device-tree-gpio-hogs-on-dual-role-gpio-pin.patch
target/linux/bcm63xx/patches-5.10/400-bcm963xx_flashmap.patch
target/linux/generic/backport-5.10/610-v5.13-10-netfilter-nftables-update-table-flags-from-the-commi.patch
target/linux/generic/hack-5.10/800-GPIO-add-named-gpio-exports.patch
target/linux/generic/hack-5.10/904-debloat_dma_buf.patch
target/linux/generic/pending-5.10/420-mtd-redboot_space.patch
target/linux/generic/pending-5.10/811-pci_disable_usb_common_quirks.patch
target/linux/ipq40xx/patches-5.10/850-soc-add-qualcomm-syscon.patch
target/linux/ipq40xx/patches-5.10/901-arm-boot-add-dts-files.patch
target/linux/ipq806x/patches-5.10/0069-arm-boot-add-dts-files.patch
target/linux/ipq806x/patches-5.10/097-3-clk-qcom-krait-add-missing-enable-disable.patch
target/linux/ipq806x/patches-5.10/850-soc-add-qualcomm-syscon.patch
target/linux/lantiq/patches-5.10/0001-MIPS-lantiq-add-pcie-driver.patch
target/linux/layerscape/patches-5.10/301-arm-dts-ls1021a-Add-LS1021A-IOT-board-support.patch
target/linux/sunxi/patches-5.10/062-add-sun8i-h3-zeropi-support.patch
target/linux/sunxi/patches-5.10/100-sunxi-h3-add-support-for-nanopi-r1.patch

index 14b00f4002e60914657a221add3e152d3ee5c337..762e4674686ccfcc92840d8b5bfd60168d93e770 100644 (file)
@@ -1,2 +1,2 @@
-LINUX_VERSION-5.10 = .136
-LINUX_KERNEL_HASH-5.10.136 = 1c099d0d59e7d9f671dfc947e16891b7a3a45efd7dfcc6b1e55a194961e45159
+LINUX_VERSION-5.10 = .137
+LINUX_KERNEL_HASH-5.10.137 = c16bcd4d1453d7e645007d0a25270f52401331c7df81c364f57bde914e1616c8
index 81b23e863ee3a2c51e5385b5a42731cb54540960..07d75b9fbae646798040262d20e9e1541f49f2ce 100644 (file)
@@ -9,7 +9,7 @@
  struct fis_image_desc {
      unsigned char name[16];      // Null terminated name
      uint32_t    flash_base;    // Address within FLASH of image
-@@ -72,6 +74,7 @@ static int parse_redboot_partitions(stru
+@@ -73,6 +75,7 @@ static int parse_redboot_partitions(stru
                                    const struct mtd_partition **pparts,
                                    struct mtd_part_parser_data *data)
  {
@@ -17,7 +17,7 @@
        int nrparts = 0;
        struct fis_image_desc *buf;
        struct mtd_partition *parts;
-@@ -239,14 +242,15 @@ static int parse_redboot_partitions(stru
+@@ -240,14 +243,15 @@ static int parse_redboot_partitions(stru
                }
        }
  #endif
@@ -35,7 +35,7 @@
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        if (nulllen > 0) {
                strcpy(nullname, nullstring);
-@@ -265,6 +269,8 @@ static int parse_redboot_partitions(stru
+@@ -266,6 +270,8 @@ static int parse_redboot_partitions(stru
        }
  #endif
        for ( ; i<nrparts; i++) {
@@ -44,7 +44,7 @@
                parts[i].size = fl->img->size;
                parts[i].offset = fl->img->flash_base;
                parts[i].name = names;
-@@ -298,6 +304,13 @@ static int parse_redboot_partitions(stru
+@@ -299,6 +305,13 @@ static int parse_redboot_partitions(stru
                fl = fl->next;
                kfree(tmp_fl);
        }
index 343eedc0753e5db61f72eada76d3477ea9d26873..68019f90eaad5aa0c71d5be795e2708ca5a687b1 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -93,12 +93,18 @@ static int parse_redboot_partitions(stru
+@@ -94,12 +94,18 @@ static int parse_redboot_partitions(stru
  
        parse_redboot_of(master);
  
@@ -19,7 +19,7 @@
                                return -EIO;
                        }
                        offset -= master->erasesize;
-@@ -111,10 +117,6 @@ static int parse_redboot_partitions(stru
+@@ -112,10 +118,6 @@ static int parse_redboot_partitions(stru
                                goto nogood;
                }
        }
@@ -30,7 +30,7 @@
  
        printk(KERN_NOTICE "Searching for RedBoot partition table in %s at offset 0x%lx\n",
               master->name, offset);
-@@ -187,6 +189,11 @@ static int parse_redboot_partitions(stru
+@@ -188,6 +190,11 @@ static int parse_redboot_partitions(stru
        }
        if (i == numslots) {
                /* Didn't find it */
index 55cf84eeff8d9a2c7b0f533af5042ca3f38fbdee..c3b73eabe9678fa9170961669bc4c900f6ba0e3f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -70,6 +70,22 @@ static void parse_redboot_of(struct mtd_
+@@ -71,6 +71,22 @@ static void parse_redboot_of(struct mtd_
        directory = dirblock;
  }
  
@@ -23,7 +23,7 @@
  static int parse_redboot_partitions(struct mtd_info *master,
                                    const struct mtd_partition **pparts,
                                    struct mtd_part_parser_data *data)
-@@ -86,6 +102,7 @@ static int parse_redboot_partitions(stru
+@@ -87,6 +103,7 @@ static int parse_redboot_partitions(stru
        int namelen = 0;
        int nulllen = 0;
        int numslots;
@@ -31,7 +31,7 @@
        unsigned long offset;
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        static char nullstring[] = "unallocated";
-@@ -200,7 +217,10 @@ static int parse_redboot_partitions(stru
+@@ -201,7 +218,10 @@ static int parse_redboot_partitions(stru
                goto out;
        }
  
@@ -43,7 +43,7 @@
                struct fis_list *new_fl, **prev;
  
                if (buf[i].name[0] == 0xff) {
-@@ -276,12 +296,13 @@ static int parse_redboot_partitions(stru
+@@ -277,12 +297,13 @@ static int parse_redboot_partitions(stru
        }
  #endif
        for ( ; i<nrparts; i++) {
@@ -59,7 +59,7 @@
                strcpy(names, fl->img->name);
  #ifdef CONFIG_MTD_REDBOOT_PARTS_READONLY
                if (!memcmp(names, "RedBoot", 8) ||
-@@ -311,7 +332,9 @@ static int parse_redboot_partitions(stru
+@@ -312,7 +333,9 @@ static int parse_redboot_partitions(stru
                fl = fl->next;
                kfree(tmp_fl);
        }
index ffdd64fb592a5da67a8305b6c36cf8bba23608c9..8fec1ca29f2251345c30b1b8be9f3d72ea30be4c 100644 (file)
@@ -35,7 +35,7 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -158,6 +158,10 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \
+@@ -159,6 +159,10 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \
        bcm958525xmc.dtb \
        bcm958622hr.dtb \
        bcm958623hr.dtb \
index 29f8b5d0fefe3e7ac997b33cd860eac8eebcc42e..6b473911abe77dcdb503bd1e91cbb0c7d0eb8a9d 100644 (file)
@@ -31,7 +31,7 @@ Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -162,6 +162,8 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \
+@@ -163,6 +163,8 @@ dtb-$(CONFIG_ARCH_BCM_NSP) += \
        bcm958625-meraki-mx64-a0.dtb \
        bcm958625-meraki-mx64w.dtb \
        bcm958625-meraki-mx64w-a0.dtb \
diff --git a/target/linux/bcm53xx/patches-5.10/081-next-ARM_dts_BCM53015-add-mr26.patch b/target/linux/bcm53xx/patches-5.10/081-next-ARM_dts_BCM53015-add-mr26.patch
deleted file mode 100644 (file)
index 4517b23..0000000
+++ /dev/null
@@ -1,242 +0,0 @@
-From 935327a73553001f8d81375c76985d05f604507f Mon Sep 17 00:00:00 2001
-From: Christian Lamparter <chunkeey@gmail.com>
-Date: Sat, 18 Jun 2022 00:00:29 +0200
-Subject: [PATCH] ARM: dts: BCM5301X: Add DT for Meraki MR26
-
-Meraki MR26 is an EOL wireless access point featuring a
-PoE ethernet port and two dual-band 3x3 MIMO 802.11n
-radios and 1x1 dual-band WIFI dedicated to scanning.
-
-Thank you Amir for the unit and PSU.
-
-Hardware info:
-SOC   : Broadcom BCM53015A1KFEBG (dual-core Cortex-A9 CPU at 800 MHz)
-RAM   : SK Hynix Inc. H5TQ1G63EFR, 1 GBit DDR3 SDRAM = 128 MiB
-NAND  : Spansion S34ML01G100TF100, 1 GBit SLC NAND Flash = 128 MiB
-ETH   : 1 GBit Ethernet Port - PoE (TPS23754 PoE Interface)
-WIFI0 : Broadcom BCM43431KMLG, BCM43431 802.11 abgn (3x3:3)
-WIFI1 : Broadcom BCM43431KMLG, BCM43431 802.11 abgn (3x3:3)
-WIFI2 : Broadcom BCM43428 "Air Marshal" 802.11 abgn (1x1:1)
-BUTTON: One reset key behind a small hole next to the Ethernet Port
-LEDS  : One amber (fault), one white (indicator) LED, separate RGB-LED
-MISC  : Atmel AT24C64 8KiB EEPROM i2c
-      : Ti INA219 26V, 12-bit, i2c output current/voltage/power monitor
-
-SERIAL:
-      WARNING: The serial port needs a TTL/RS-232 3V3 level converter!
-      The Serial setting is 115200-8-N-1. The board has a populated
-      right angle 1x4 0.1" pinheader.
-      The pinout is: VCC (next to J3, has the pin 1 indicator), RX, TX, GND.
-
-Odd stuff:
-
-- uboot does not support lzma compression, but gzip'd uImage/DTB work.
-- uboot claims to support FIT, but fails to pass the DTB to the kernel.
-  Appending the dtb after the kernel image works.
-- RGB-controller is supported through an external userspace program.
-- The ubi partition contains a "board-config" volume. It stores the
-  MAC Address (0x66 in binary) and Serial No. (0x7c alpha-numerical).
-- SoC's temperature sensor always reports that it is on fire.
-  This causes the system to immediately shutdown! Looking at reported
-  "418 degree Celsius" suggests that this sensor is not working.
-
-WIFI:
-b43 is able to initialize all three WIFIs @ 802.11bg.
-| b43-phy0: Broadcom 43431 WLAN found (core revision 29)
-| bcma-pci-bridge 0000:01:00.0: bus1: Switched to core: 0x812
-| b43-phy0: Found PHY: Analog 9, Type 7 (HT), Revision 1
-| b43-phy0: Found Radio: Manuf 0x17F, ID 0x2059, Revision 0, Version 1
-| b43-phy0 warning: 5 GHz band is unsupported on this PHY
-| b43-phy1: Broadcom 43431 WLAN found (core revision 29)
-| bcma-pci-bridge 0001:01:00.0: bus2: Switched to core: 0x812
-| b43-phy1: Found PHY: Analog 9, Type 7 (HT), Revision 1
-| b43-phy1: Found Radio: Manuf 0x17F, ID 0x2059, Revision 0, Version 1
-| b43-phy1 warning: 5 GHz band is unsupported on this PHY
-| b43-phy2: Broadcom 43228 WLAN found (core revision 30)
-| bcma-pci-bridge 0002:01:00.0: bus3: Switched to core: 0x812
-| b43-phy2: Found PHY: Analog 9, Type 4 (N), Revision 16
-| b43-phy2: Found Radio: Manuf 0x17F, ID 0x2057, Revision 9, Version 1
-| Broadcom 43xx driver loaded [ Features: NL ]
-
-Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
-Signed-off-by: Florian Fainelli <f.fainelli@gmail.com>
----
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm53015-meraki-mr26.dts
-@@ -0,0 +1,166 @@
-+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
-+/*
-+ * Broadcom BCM470X / BCM5301X ARM platform code.
-+ * DTS for Meraki MR26 / Codename: Venom
-+ *
-+ * Copyright (C) 2022 Christian Lamparter <chunkeey@gmail.com>
-+ */
-+
-+/dts-v1/;
-+
-+#include "bcm4708.dtsi"
-+#include "bcm5301x-nand-cs0-bch8.dtsi"
-+#include <dt-bindings/leds/common.h>
-+
-+/ {
-+      compatible = "meraki,mr26", "brcm,bcm53015", "brcm,bcm4708";
-+      model = "Meraki MR26";
-+
-+      memory@0 {
-+              reg = <0x00000000 0x08000000>;
-+              device_type = "memory";
-+      };
-+
-+      leds {
-+              compatible = "gpio-leds";
-+
-+              led-0 {
-+                      function = LED_FUNCTION_FAULT;
-+                      color = <LED_COLOR_ID_AMBER>;
-+                      gpios = <&chipcommon 13 GPIO_ACTIVE_HIGH>;
-+                      panic-indicator;
-+              };
-+              led-1 {
-+                      function = LED_FUNCTION_INDICATOR;
-+                      color = <LED_COLOR_ID_WHITE>;
-+                      gpios = <&chipcommon 12 GPIO_ACTIVE_HIGH>;
-+              };
-+      };
-+
-+      keys {
-+              compatible = "gpio-keys";
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+
-+              key-restart {
-+                      label = "Reset";
-+                      linux,code = <KEY_RESTART>;
-+                      gpios = <&chipcommon 11 GPIO_ACTIVE_LOW>;
-+              };
-+      };
-+};
-+
-+&uart0 {
-+      clock-frequency = <50000000>;
-+      /delete-property/ clocks;
-+};
-+
-+&uart1 {
-+      status = "disabled";
-+};
-+
-+&gmac0 {
-+      status = "okay";
-+};
-+
-+&gmac1 {
-+      status = "disabled";
-+};
-+&gmac2 {
-+      status = "disabled";
-+};
-+&gmac3 {
-+      status = "disabled";
-+};
-+
-+&nandcs {
-+      nand-ecc-algo = "hw";
-+
-+      partitions {
-+              compatible = "fixed-partitions";
-+              #address-cells = <0x1>;
-+              #size-cells = <0x1>;
-+
-+              partition@0 {
-+                      label = "u-boot";
-+                      reg = <0x0 0x200000>;
-+                      read-only;
-+              };
-+
-+              partition@200000 {
-+                      label = "u-boot-env";
-+                      reg = <0x200000 0x200000>;
-+                      /* empty */
-+              };
-+
-+              partition@400000 {
-+                      label = "u-boot-backup";
-+                      reg = <0x400000 0x200000>;
-+                      /* empty */
-+              };
-+
-+              partition@600000 {
-+                      label = "u-boot-env-backup";
-+                      reg = <0x600000 0x200000>;
-+                      /* empty */
-+              };
-+
-+              partition@800000 {
-+                      label = "ubi";
-+                      reg = <0x800000 0x7780000>;
-+              };
-+      };
-+};
-+
-+&srab {
-+      status = "okay";
-+
-+      ports {
-+              port@0 {
-+                      reg = <0>;
-+                      label = "poe";
-+              };
-+
-+              port@5 {
-+                      reg = <5>;
-+                      label = "cpu";
-+                      ethernet = <&gmac0>;
-+
-+                      fixed-link {
-+                              speed = <1000>;
-+                              duplex-full;
-+                      };
-+              };
-+      };
-+};
-+
-+&i2c0 {
-+      status = "okay";
-+
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&pinmux_i2c>;
-+
-+      clock-frequency = <100000>;
-+
-+      ina219@40 {
-+              compatible = "ti,ina219"; /* PoE power */
-+              reg = <0x40>;
-+              shunt-resistor = <60000>; /* = 60 mOhms */
-+      };
-+
-+      eeprom@56 {
-+              compatible = "atmel,24c64";
-+              reg = <0x56>;
-+              pagesize = <32>;
-+              read-only;
-+              #address-cells = <1>;
-+              #size-cells = <1>;
-+
-+              /* it's empty */
-+      };
-+};
-+
-+&thermal {
-+      status = "disabled";
-+      /* does not work, reads 418 degree Celsius */
-+};
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -129,6 +129,7 @@ dtb-$(CONFIG_ARCH_BCM_5301X) += \
-       bcm47094-luxul-xwr-3150-v1.dtb \
-       bcm47094-netgear-r8500.dtb \
-       bcm47094-phicomm-k3.dtb \
-+      bcm53015-meraki-mr26.dtb \
-       bcm53016-meraki-mr32.dtb \
-       bcm94708.dtb \
-       bcm94709.dtb \
index 045a3bc826de36a635b4f3eb745ab0b4457f76d5..47677075ed25f3c5a806043ff70dd88d7c9a4be5 100644 (file)
@@ -99,7 +99,7 @@ Signed-off-by: Jonas Gorski <jonas.gorski@gmail.com>
                if (ret < 0) {
                        pr_err("%s: failed to add hogs for %pOF\n", __func__,
                               rd->dn);
-@@ -1035,9 +1045,11 @@ int of_gpiochip_add(struct gpio_chip *ch
+@@ -1037,9 +1047,11 @@ int of_gpiochip_add(struct gpio_chip *ch
  
        of_node_get(chip->of_node);
  
index 5a9532c3214890c338fc7f7c885250c5b7b7b404..bb43576b85ccc94ecb3d7dcd002e6043c2765224 100644 (file)
@@ -23,7 +23,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
        .width                  = 2,
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -84,6 +84,7 @@ static int parse_redboot_partitions(stru
+@@ -85,6 +85,7 @@ static int parse_redboot_partitions(stru
        int nulllen = 0;
        int numslots;
        unsigned long offset;
@@ -31,7 +31,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
  #ifdef CONFIG_MTD_REDBOOT_PARTS_UNALLOCATED
        static char nullstring[] = "unallocated";
  #endif
-@@ -190,6 +191,16 @@ static int parse_redboot_partitions(stru
+@@ -191,6 +192,16 @@ static int parse_redboot_partitions(stru
                goto out;
        }
  
@@ -48,7 +48,7 @@ Signed-off-by: Axel Gembe <ago@bastart.eu.org>
        for (i = 0; i < numslots; i++) {
                struct fis_list *new_fl, **prev;
  
-@@ -210,10 +221,10 @@ static int parse_redboot_partitions(stru
+@@ -211,10 +222,10 @@ static int parse_redboot_partitions(stru
                        goto out;
                }
                new_fl->img = &buf[i];
index d2076031ca3b86ac80dad51972fc7402a3c50976..5ab2718ecbf54edeb683a8deda048c4a29ddf98f 100644 (file)
@@ -34,7 +34,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        struct nft_set                  *set;
 --- a/net/netfilter/nf_tables_api.c
 +++ b/net/netfilter/nf_tables_api.c
-@@ -892,6 +892,12 @@ static void nf_tables_table_disable(stru
+@@ -893,6 +893,12 @@ static void nf_tables_table_disable(stru
        nft_table_disable(net, table, 0);
  }
  
@@ -47,7 +47,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
  static int nf_tables_updtable(struct nft_ctx *ctx)
  {
        struct nft_trans *trans;
-@@ -915,19 +921,17 @@ static int nf_tables_updtable(struct nft
+@@ -916,19 +922,17 @@ static int nf_tables_updtable(struct nft
  
        if ((flags & NFT_TABLE_F_DORMANT) &&
            !(ctx->table->flags & NFT_TABLE_F_DORMANT)) {
@@ -70,7 +70,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
        nft_trans_table_update(trans) = true;
        list_add_tail(&trans->list, &ctx->net->nft.commit_list);
        return 0;
-@@ -7923,11 +7927,10 @@ static int nf_tables_commit(struct net *
+@@ -7931,11 +7935,10 @@ static int nf_tables_commit(struct net *
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
@@ -86,7 +86,7 @@ Signed-off-by: Pablo Neira Ayuso <pablo@netfilter.org>
                        } else {
                                nft_clear(net, trans->ctx.table);
                        }
-@@ -8140,11 +8143,9 @@ static int __nf_tables_abort(struct net
+@@ -8148,11 +8151,9 @@ static int __nf_tables_abort(struct net
                switch (trans->msg_type) {
                case NFT_MSG_NEWTABLE:
                        if (nft_trans_table_update(trans)) {
index 2d67353ed9d41a45c4ca7cabeb2568259893075b..6367ee9a0b6ad6317334ec680b95b35ea22410e4 100644 (file)
@@ -15,7 +15,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
  
  #include "gpiolib.h"
  #include "gpiolib-of.h"
-@@ -1044,3 +1046,72 @@ void of_gpiochip_remove(struct gpio_chip
+@@ -1046,3 +1048,72 @@ void of_gpiochip_remove(struct gpio_chip
  {
        of_node_put(chip->of_node);
  }
index 3c97b0e07c9f760a93d9d95aa672762779915cff..333ed12b06693d3dc97cc5fdc9de6a1215eff7a2 100644 (file)
@@ -72,7 +72,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 +MODULE_LICENSE("GPL");
 --- a/kernel/sched/core.c
 +++ b/kernel/sched/core.c
-@@ -3066,6 +3066,7 @@ int wake_up_state(struct task_struct *p,
+@@ -3071,6 +3071,7 @@ int wake_up_state(struct task_struct *p,
  {
        return try_to_wake_up(p, state, 0);
  }
index a3cd4ecf1f9bf799ad57f6d7892838df81bcaae4..5be2a2246e379ca231b327b620e56c81d889f74e 100644 (file)
@@ -11,7 +11,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
 
 --- a/drivers/mtd/parsers/redboot.c
 +++ b/drivers/mtd/parsers/redboot.c
-@@ -279,14 +279,21 @@ static int parse_redboot_partitions(stru
+@@ -280,14 +280,21 @@ static int parse_redboot_partitions(stru
  #endif
                names += strlen(names)+1;
  
index cf52fa36ca0662a34d00a773293ce21e56135ae6..488f90a8d4f91f3e1a2db374bced8e5a68ed4c94 100644 (file)
@@ -98,7 +98,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  #endif  /*  __LINUX_USB_PCI_QUIRKS_H  */
 --- a/include/linux/usb/hcd.h
 +++ b/include/linux/usb/hcd.h
-@@ -486,7 +486,14 @@ extern int usb_hcd_pci_probe(struct pci_
+@@ -487,7 +487,14 @@ extern int usb_hcd_pci_probe(struct pci_
  extern void usb_hcd_pci_remove(struct pci_dev *dev);
  extern void usb_hcd_pci_shutdown(struct pci_dev *dev);
  
index df0b70d72e108a4d134ffe1e356f18183c4e0c41..b39237b1ddd9ddd2c0a7aa9cd7324fc27cbb56dc 100644 (file)
@@ -12,7 +12,7 @@ Subject: SoC: add qualcomm syscon
  obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -189,6 +189,13 @@ config QCOM_SOCINFO
+@@ -190,6 +190,13 @@ config QCOM_SOCINFO
         Say yes here to support the Qualcomm socinfo driver, providing
         information about the SoC to user space.
  
index 21de771fca4bad781382a2a255055735a8e20f73..952092d1f729ad812a2f0ce6cc2f3222cf4da061 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -903,11 +903,79 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -904,11 +904,79 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-apq8074-dragonboard.dtb \
        qcom-apq8084-ifc6540.dtb \
        qcom-apq8084-mtp.dtb \
index a7eacf311bbb9a48b8605f484ae847a014824cc5..4c42f40e3d78b183708b73e815cad81258b5a464 100644 (file)
@@ -10,7 +10,7 @@ Signed-off-by: John Crispin <john@phrozen.org>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -908,8 +908,30 @@ dtb-$(CONFIG_ARCH_QCOM) += \
+@@ -909,8 +909,30 @@ dtb-$(CONFIG_ARCH_QCOM) += \
        qcom-ipq4019-ap.dk04.1-c3.dtb \
        qcom-ipq4019-ap.dk07.1-c1.dtb \
        qcom-ipq4019-ap.dk07.1-c2.dtb \
index bf1c1a4a2fdf2c2202548c86d435947edcbe9bc5..78068f359c43eb195dc127c3d8fec2a821b0dff3 100644 (file)
@@ -13,7 +13,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
 
 --- a/drivers/clk/qcom/clk-krait.c
 +++ b/drivers/clk/qcom/clk-krait.c
-@@ -68,7 +68,25 @@ static u8 krait_mux_get_parent(struct cl
+@@ -73,7 +73,25 @@ static u8 krait_mux_get_parent(struct cl
        return clk_mux_val_to_index(hw, mux->parent_map, 0, sel);
  }
  
@@ -39,7 +39,7 @@ Signed-off-by: Ansuel Smith <ansuelsmth@gmail.com>
        .set_parent = krait_mux_set_parent,
        .get_parent = krait_mux_get_parent,
        .determine_rate = __clk_mux_determine_rate_closest,
-@@ -79,8 +97,13 @@ EXPORT_SYMBOL_GPL(krait_mux_clk_ops);
+@@ -84,8 +102,13 @@ EXPORT_SYMBOL_GPL(krait_mux_clk_ops);
  static long krait_div2_round_rate(struct clk_hw *hw, unsigned long rate,
                                  unsigned long *parent_rate)
  {
index 8325e103893ce6786c014a845977386f4d5b306a..ec9027ae47b0c39b7b10f5f348b64fdcac3e658c 100644 (file)
@@ -12,7 +12,7 @@ Subject: SoC: add qualcomm syscon
  obj-$(CONFIG_QCOM_RPMHPD) += rpmhpd.o
 --- a/drivers/soc/qcom/Kconfig
 +++ b/drivers/soc/qcom/Kconfig
-@@ -189,6 +189,13 @@ config QCOM_SOCINFO
+@@ -190,6 +190,13 @@ config QCOM_SOCINFO
         Say yes here to support the Qualcomm socinfo driver, providing
         information about the SoC to user space.
  
index 241fa864a1a237b18ac7df26a5509ac48e92b169..99bed24cfd566725d693b42c87b1e3420ff1fcae 100644 (file)
@@ -5492,7 +5492,7 @@ Signed-off-by: John Crispin <blogic@openwrt.org>
                                         unsigned long type);
 --- a/include/linux/pci_ids.h
 +++ b/include/linux/pci_ids.h
-@@ -1076,6 +1076,12 @@
+@@ -1079,6 +1079,12 @@
  #define PCI_DEVICE_ID_SGI_IOC3                0x0003
  #define PCI_DEVICE_ID_SGI_LITHIUM     0x1002
  
index c7ecb985676ac036ea438b3384e3533c35137f5a..ce6a19c896fa04311300ab2355835e8a6240afe4 100644 (file)
@@ -14,7 +14,7 @@ Signed-off-by: Yangbo Lu <yangbo.lu@nxp.com>
 
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -665,7 +665,8 @@ dtb-$(CONFIG_SOC_LS1021A) += \
+@@ -666,7 +666,8 @@ dtb-$(CONFIG_SOC_LS1021A) += \
        ls1021a-moxa-uc-8410a.dtb \
        ls1021a-qds.dtb \
        ls1021a-tsn.dtb \
index 35e14aa4efcebe209983d150ff72b0319a40c34b..3dd37fedbaf6099da3599e3f1caa0c770797cfdb 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -1203,6 +1203,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
+@@ -1204,6 +1204,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
        sun8i-h3-orangepi-zero-plus2.dtb \
        sun8i-h3-rervision-dvk.dtb \
        sun8i-h3-emlid-neutis-n5h3-devboard.dtb \
index 9a969d5e00c4840888e90bd04bb5812b80c4e020..cbdf5ed3d4d3f71e229368b5294685a4c9a8bee8 100644 (file)
@@ -27,7 +27,7 @@ Signed-off-by: Jayantajit Gogoi <jayanta.gogoi525@gmail.com>
            - const: gemei,g9
 --- a/arch/arm/boot/dts/Makefile
 +++ b/arch/arm/boot/dts/Makefile
-@@ -1193,6 +1193,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
+@@ -1194,6 +1194,7 @@ dtb-$(CONFIG_MACH_SUN8I) += \
        sun8i-h3-nanopi-m1-plus.dtb \
        sun8i-h3-nanopi-neo.dtb \
        sun8i-h3-nanopi-neo-air.dtb \