malta: remove hack to determine entry point
authorFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 18:19:34 +0000 (19:19 +0100)
committerFelix Fietkau <nbd@nbd.name>
Fri, 13 Jan 2017 18:46:45 +0000 (19:46 +0100)
Malta has CONFIG_BOOT_RAW set, so jumping to the load address is valid

Signed-off-by: Felix Fietkau <nbd@nbd.name>
target/linux/malta/image/Makefile

index 180e045ec7b12c204a49a9a1cacb57ed45fad2d5..31eb7ca0bbd0fa4b8dda644f6fc1b9e919a9fc64 100644 (file)
@@ -7,10 +7,6 @@
 include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/image.mk
 
-define get_kernel_entry
-0x$(shell $(TARGET_CROSS)nm $(1) 2>/dev/null | grep " kernel_entry" | cut -f1 -d ' ')
-endef
-
 define CompressLzma
   $(STAGING_DIR_HOST)/bin/lzma e $(1) -lc1 -lp2 -pb2 $(2)
 endef
@@ -21,7 +17,7 @@ endef
 
 define MkuImage
        mkimage -A mips -O linux -T kernel -a 0x80100000 -C $(1) $(2) \
-               -e $(call get_kernel_entry,$(KDIR)/vmlinux.debug) -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
+               -e 0x80100000 -n 'MIPS OpenWrt Linux-$(LINUX_VERSION)' \
                -d $(3) $(4)
 endef