opkg: update to r528, refresh patches
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Apr 2010 23:23:40 +0000 (23:23 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 18 Apr 2010 23:23:40 +0000 (23:23 +0000)
SVN-Revision: 21008

package/opkg/Makefile
package/opkg/patches/000-upstream-fix_configure_order.patch [deleted file]
package/opkg/patches/003-fs_overlay_support.patch
package/opkg/patches/009-remove-upgrade-all.patch
package/opkg/patches/010-remove-flag.patch

index 81f7b4a4a02ba03447a27fc60a1ac50e0650ab61..c18f8e731930a208a15f8dc8504eb35bd32aadbd 100644 (file)
@@ -8,9 +8,9 @@ include $(TOPDIR)/rules.mk
 include $(INCLUDE_DIR)/kernel.mk
 
 PKG_NAME:=opkg
-PKG_REV:=513
+PKG_REV:=528
 PKG_VERSION:=$(PKG_REV)
-PKG_RELEASE:=2
+PKG_RELEASE:=1
 
 PKG_SOURCE_PROTO:=svn
 PKG_SOURCE_VERSION:=$(PKG_REV)
diff --git a/package/opkg/patches/000-upstream-fix_configure_order.patch b/package/opkg/patches/000-upstream-fix_configure_order.patch
deleted file mode 100644 (file)
index dcd1b54..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
-http://code.google.com/p/opkg/source/detail?r=521
-
---- a/libopkg/opkg_cmd.c
-+++ b/libopkg/opkg_cmd.c
-@@ -390,8 +390,8 @@ opkg_configure_packages(char *pkg_name)
-            goto error;
-      }
-     
--     for(i = 0; i < all->len; i++) {
--        pkg = all->pkgs[i];
-+     for(i = 0; i < ordered->len; i++) {
-+        pkg = ordered->pkgs[i];
-         if (pkg_name && fnmatch(pkg_name, pkg->name, 0)) 
-              continue;
index 4fed4d12e259371a521be7d47bbb292f1871ce74..49dd1ff655d32fb616bd2bebbd1839409ef10873 100644 (file)
@@ -18,7 +18,7 @@ Signed-off-by: Nicolas Thill <nico@openwrt.org>
 +++ b/libopkg/opkg_conf.h
 @@ -76,6 +76,7 @@ struct opkg_conf
       int check_signature;
-      int nodeps; /* do not follow dependences */
+      int nodeps; /* do not follow dependencies */
       char *offline_root;
 +     char *overlay_root;
       int query_all;
index be76ef53ce84083b91c78716fcfa753192e0b540..6dfa3db838556d61a93000fcc71ba2ec19557a82 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libopkg/opkg_cmd.c
 +++ b/libopkg/opkg_cmd.c
-@@ -498,17 +498,6 @@ opkg_upgrade_cmd(int argc, char **argv)
+@@ -500,17 +500,6 @@ opkg_upgrade_cmd(int argc, char **argv)
                    opkg_install_by_name(arg);
                 }
          }
@@ -17,8 +17,8 @@
 -        pkg_vec_free(installed);
       }
  
-      opkg_configure_packages(NULL);
-@@ -1166,7 +1155,7 @@ opkg_print_architecture_cmd(int argc, ch
+      r = opkg_configure_packages(NULL);
+@@ -1173,7 +1162,7 @@ opkg_print_architecture_cmd(int argc, ch
     array for easier maintenance */
  static opkg_cmd_t cmds[] = {
       {"update", 0, (opkg_cmd_fun_t)opkg_update_cmd, PFM_DESCRIPTION|PFM_SOURCE},
index c242bea31f4bbda260c3098356a797423511ed38..6659c2937517f1146e57297eab2aaf06f97662c6 100644 (file)
@@ -1,6 +1,6 @@
 --- a/libopkg/opkg_cmd.c
 +++ b/libopkg/opkg_cmd.c
-@@ -738,49 +738,6 @@ opkg_remove_cmd(int argc, char **argv)
+@@ -745,49 +745,6 @@ opkg_remove_cmd(int argc, char **argv)
  }
  
  static int
@@ -50,7 +50,7 @@
  opkg_files_cmd(int argc, char **argv)
  {
       pkg_t *pkg;
-@@ -1162,7 +1119,6 @@ static opkg_cmd_t cmds[] = {
+@@ -1169,7 +1126,6 @@ static opkg_cmd_t cmds[] = {
       {"list_upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE},
       {"list-upgradable", 0, (opkg_cmd_fun_t)opkg_list_upgradable_cmd, PFM_SOURCE},
       {"info", 0, (opkg_cmd_fun_t)opkg_info_cmd, 0},