compile fix for diag
authorFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 15:43:16 +0000 (15:43 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 22 Oct 2005 15:43:16 +0000 (15:43 +0000)
SVN-Revision: 2243

openwrt/target/linux/package/diag/Makefile

index 42765aedfea0715c7330fa36409efd5651b3e388..47908f0866a0338e1f67dba61f3c2897f1f3d20c 100644 (file)
@@ -26,7 +26,7 @@ $(PKG_BUILD_DIR)/.prepared:
        touch $@
 
 $(PKG_BUILD_DIR)/.built:
-       $(TARGET_CC) $(DIAG_FLAGS) -o $@ diag_led.c
+       $(TARGET_CC) $(DIAG_FLAGS) -o $(PKG_BUILD_DIR)/diag.o diag_led.c
        touch $@
        
 $(IPKG_KMOD_DIAG):