ath10k-firmware: add qca99x0 firmware
authorFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 22:01:22 +0000 (22:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 30 Oct 2015 22:01:22 +0000 (22:01 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 47295

package/firmware/ath10k-firmware/Makefile

index bce0f80639dee44d2f3b3ebdb262b1b7d8564707..ac955438672f22ab382fd3967b4d01580afa974e 100644 (file)
@@ -33,6 +33,15 @@ define Package/ath10k-firmware-qca988x
   TITLE:=ath10k firmware for QCA988x devices
 endef
 
+define Package/ath10k-firmware-qca99x0
+  SECTION:=kernel
+  CATEGORY:=Kernel modules
+  SUBMENU:=$(WMENU)
+  URL:=$(PKG_SOURCE_URL)
+  DEPENDS:=kmod-ath10k
+  TITLE:=ath10k firmware for QCA99x0 devices
+endef
+
 define Build/Compile
 
 endef
@@ -47,4 +56,15 @@ define Package/ath10k-firmware-qca988x/install
                $(1)/lib/firmware/ath10k/QCA988X/hw2.0/firmware-5.bin
 endef
 
+define Package/ath10k-firmware-qca99x0/install
+       $(INSTALL_DIR) $(1)/lib/firmware/ath10k/QCA99X0/hw2.0
+       $(INSTALL_DATA) \
+               $(PKG_BUILD_DIR)/QCA99X0/hw2.0/boardData_AR900B_CUS239_5G_v2_001.bin \
+               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/board.bin
+       $(INSTALL_DATA) \
+               $(PKG_BUILD_DIR)/QCA99X0/hw2.0/firmware-5.bin_10.4.1.00030-1 \
+               $(1)/lib/firmware/ath10k/QCA99X0/hw2.0/firmware-5.bin
+endef
+
 $(eval $(call BuildPackage,ath10k-firmware-qca988x))
+$(eval $(call BuildPackage,ath10k-firmware-qca99x0))