pkg-config: fix occasional install problem
authorLuka Perkov <luka@openwrt.org>
Wed, 20 Nov 2013 22:09:11 +0000 (22:09 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 20 Nov 2013 22:09:11 +0000 (22:09 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38886

tools/pkg-config/Makefile
tools/pkg-config/patches/001-fix-package-rebuild.patch [new file with mode: 0644]

index 6bd53f8610749791b0f2c7881aa01cf78aea8b3d..0edc807e9da74310b384af23d815872e8371168c 100644 (file)
@@ -1,5 +1,5 @@
 # 
-# Copyright (C) 2006 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
diff --git a/tools/pkg-config/patches/001-fix-package-rebuild.patch b/tools/pkg-config/patches/001-fix-package-rebuild.patch
new file mode 100644 (file)
index 0000000..54f549c
--- /dev/null
@@ -0,0 +1,22 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -39,7 +39,7 @@
+ if HOST_TOOL
+ host_tool = $(host)-pkg-config$(EXEEXT)
+ install-exec-hook:
+-      cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++      cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ uninstall-hook:
+       cd $(DESTDIR)$(bindir) && rm -f $(host_tool)
+ endif
+--- a/Makefile.in
++++ b/Makefile.in
+@@ -1093,7 +1093,7 @@
+       uninstall-man1
+ @HOST_TOOL_TRUE@install-exec-hook:
+-@HOST_TOOL_TRUE@      cd $(DESTDIR)$(bindir) && $(LN) pkg-config$(EXEEXT) $(host_tool)
++@HOST_TOOL_TRUE@      cd $(DESTDIR)$(bindir) && $(LN) -f pkg-config$(EXEEXT) $(host_tool)
+ @HOST_TOOL_TRUE@uninstall-hook:
+ @HOST_TOOL_TRUE@      cd $(DESTDIR)$(bindir) && rm -f $(host_tool)