ath79: Add support for OpenMesh MR600 v2
authorSven Eckelmann <sven@narfation.org>
Mon, 23 Nov 2020 12:41:34 +0000 (13:41 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Tue, 19 Jan 2021 14:39:36 +0000 (15:39 +0100)
Device specifications:
======================

* Qualcomm/Atheros AR9344 rev 2
* 560/450/225 MHz (CPU/DDR/AHB)
* 128 MB of RAM
* 16 MB of SPI NOR flash
  - 2x 7 MB available; but one of the 7 MB regions is the recovery image
* 2T2R 2.4 GHz Wi-Fi
* 2T2R 5 GHz Wi-Fi
* 8x GPIO-LEDs (6x wifi, 1x wps, 1x power)
* 1x GPIO-button (reset)
* external h/w watchdog (enabled by default))
* TTL pins are on board (arrow points to VCC, then follows: GND, TX, RX)
* 1x ethernet
  - AR8035 ethernet PHY (RGMII)
  - 10/100/1000 Mbps Ethernet
  - 802.3af POE
  - used as LAN interface
* 12-24V 1A DC
* internal antennas

Flashing instructions:
======================

Various methods can be used to install the actual image on the flash.
Two easy ones are:

ap51-flash
----------

The tool ap51-flash (https://github.com/ap51-flash/ap51-flash) should be
used to transfer the image to the u-boot when the device boots up.

initramfs from TFTP
-------------------

The serial console must be used to access the u-boot shell during bootup.
It can then be used to first boot up the initramfs image from a TFTP server
(here with the IP 192.168.1.21):

   setenv serverip 192.168.1.21
   setenv ipaddr 192.168.1.1
   tftpboot 0c00000 <filename-of-initramfs-kernel>.bin && bootm $fileaddr

The actual sysupgrade image can then be transferred (on the LAN port) to the
device via

  scp <filename-of-squashfs-sysupgrade>.bin root@192.168.1.1:/tmp/

On the device, the sysupgrade must then be started using

  sysupgrade -n /tmp/<filename-of-squashfs-sysupgrade>.bin

Signed-off-by: Sven Eckelmann <sven@narfation.org>
[rebase, add LED migration]
Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/ath79
target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts [new file with mode: 0644]
target/linux/ath79/generic/base-files/etc/board.d/02_network
target/linux/ath79/generic/base-files/etc/hotplug.d/firmware/10-ath9k-eeprom
target/linux/ath79/generic/base-files/etc/uci-defaults/04_led_migration
target/linux/ath79/generic/base-files/lib/upgrade/platform.sh
target/linux/ath79/image/generic.mk

index 8bc2c00ba5c257856c4b644c4a3a93a63db1304c..4847653f3f0714f9596c32f9020237ee48e157d5 100644 (file)
@@ -10,7 +10,7 @@ include $(TOPDIR)/rules.mk
 PKG_NAME:=uboot-envtools
 PKG_DISTNAME:=u-boot
 PKG_VERSION:=2020.04
-PKG_RELEASE:=17
+PKG_RELEASE:=18
 
 PKG_SOURCE:=$(PKG_DISTNAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
index 3cdb71a69ee27bee4b6c5a2042f04c85ebd6a20d..028b00ac4366854f0e7c5f84a321a6f24b5d2156 100644 (file)
@@ -49,6 +49,7 @@ netgear,wnr612-v2|\
 ocedo,koala|\
 ocedo,raccoon|\
 openmesh,mr600-v1|\
+openmesh,mr600-v2|\
 openmesh,om5p|\
 openmesh,om5p-ac-v2|\
 samsung,wam250|\
diff --git a/target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts b/target/linux/ath79/dts/ar9344_openmesh_mr600-v2.dts
new file mode 100644 (file)
index 0000000..9880667
--- /dev/null
@@ -0,0 +1,71 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "ar9344_openmesh_mr600.dtsi"
+
+/ {
+       compatible = "openmesh,mr600-v2", "qca,ar9344";
+       model = "OpenMesh MR600 v2";
+
+       aliases {
+               led-boot = &led_power_blue;
+               led-failsafe = &led_power_blue;
+               led-running = &led_power_blue;
+               led-upgrade = &led_power_blue;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               wifi5g_red {
+                       label = "red:wifi5g";
+                       gpios = <&gpio 12 GPIO_ACTIVE_LOW>;
+               };
+
+               wps_blue {
+                       label = "blue:wps";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               led_power_blue: power_blue {
+                       label = "blue:power";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+                       default-state = "on";
+               };
+
+               wifi2g_green {
+                       label = "green:wifi2g";
+                       gpios = <&gpio 18 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy1tpt";
+               };
+
+               wifi2g_yellow {
+                       label = "yellow:wifi2g";
+                       gpios = <&gpio 19 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi2g_red {
+                       label = "red:wifi2g";
+                       gpios = <&gpio 20 GPIO_ACTIVE_LOW>;
+               };
+
+               wifi5g_green {
+                       label = "green:wifi5g";
+                       gpios = <&gpio 21 GPIO_ACTIVE_LOW>;
+                       linux,default-trigger = "phy0tpt";
+               };
+
+               wifi5g_yellow {
+                       label = "yellow:wifi5g";
+                       gpios = <&gpio 22 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       watchdog {
+               compatible = "linux,wdt-gpio";
+               gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               hw_algo = "toggle";
+               /* hw_margin_ms is actually 300s but driver limits it to 60s */
+               hw_margin_ms = <60000>;
+               always-running;
+       };
+};
index df0842fc637e40cf6660f9b84a4e324dffc73720..3c37781c0e03c780846d0d7c16343ce2eb71f19c 100755 (executable)
@@ -47,6 +47,7 @@ ath79_setup_interfaces()
        ocedo,koala|\
        ocedo,raccoon|\
        openmesh,mr600-v1|\
+       openmesh,mr600-v2|\
        pcs,cap324|\
        pisen,ts-d084|\
        pisen,wmb001n|\
index 150c70d68b722b9c06c19510767e2c1b67b7b9d4..d50d8d9f829047cbc2103e125b5f0a64f42fa47f 100644 (file)
@@ -120,7 +120,8 @@ case "$FIRMWARE" in
        ubnt,rocket-m)
                caldata_extract "art" 0x1000 0x1000
                ;;
-       openmesh,mr600-v1)
+       openmesh,mr600-v1|\
+       openmesh,mr600-v2)
                caldata_extract "ART" 0x5000 0x440
                ;;
        wd,mynet-n750)
index 871d84ed63080073155db39d871669bf2362142d..88c4f527b7dad964f143a4c3028749d7a86ba1d6 100644 (file)
@@ -20,6 +20,9 @@ glinet,gl-mifi)
 openmesh,mr600-v1)
        migrate_leds ":wlan58=:wifi5g"
        ;;
+openmesh,mr600-v2)
+       migrate_leds ":wlan24=:wifi2g" ":wlan58=:wifi5g"
+       ;;
 pcs,cap324)
        migrate_leds "lan:amber=amber:lan" "lan:green=green:lan"
        ;;
index 81dd9115647ec054995fd3b96e27ed14961a7585..e14adb38fab6f6c7370e61adb07e39113c159b51 100644 (file)
@@ -51,6 +51,7 @@ platform_do_upgrade() {
                redboot_fis_do_upgrade "$1" linux
                ;;
        openmesh,mr600-v1|\
+       openmesh,mr600-v2|\
        openmesh,om2p-v2|\
        openmesh,om2p-v4|\
        openmesh,om2p-hs-v1|\
index 14546f6adecf8c056774f7884ac33015eaa03d9d..9a182cab79b68f9604d2416b13fd3b2bb5349066 100644 (file)
@@ -1545,6 +1545,13 @@ define Device/openmesh_mr600-v1
 endef
 TARGET_DEVICES += openmesh_mr600-v1
 
+define Device/openmesh_mr600-v2
+  $(Device/openmesh_mr600-common)
+  DEVICE_VARIANT := v2
+  SUPPORTED_DEVICES += mr600v2
+endef
+TARGET_DEVICES += openmesh_mr600-v2
+
 define Device/openmesh_om2p-common
   DEVICE_VENDOR := OpenMesh
   DEVICE_PACKAGES := uboot-envtools