include/image.mk: /tmp should have mode 1777
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jul 2012 11:48:54 +0000 (11:48 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 1 Jul 2012 11:48:54 +0000 (11:48 +0000)
On the off chance that the root filesystem's /tmp is used directly as a
temporary directory instead of having a tmpfs mounted over it, it should have
the sticky bit set.

Signed-off-by: Mark Mentovai <mark@moxienet.com>
SVN-Revision: 32572

include/image.mk

index b0d6dfae610df3bd63516f22d0f8029a8bb7af30..1977fc84c0436cdffd7779d529ef8ea4e11266c5 100644 (file)
@@ -146,7 +146,7 @@ define Image/mkfs/prepare/default
        - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
        - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod u+rwx,g+rx,o+rx
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
-       chmod 0777 $(TARGET_DIR)/tmp
+       chmod 1777 $(TARGET_DIR)/tmp
 endef
 
 define Image/mkfs/prepare