tools: install a fake empty ldconfig script to prevent the system ldconfig from messi...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 11 Sep 2014 23:13:29 +0000 (23:13 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 11 Sep 2014 23:13:29 +0000 (23:13 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42480

tools/Makefile

index 4a30c8c5395345ca854c2d54cc21672d666bbb5d..09a0c8cebc338f8d040c6ea251a559d789789d78 100644 (file)
@@ -133,6 +133,10 @@ $(STAGING_DIR_HOST)/bin/stat: $(STAGING_DIR)/.prepared
                false; \
        fi
 
+$(STAGING_DIR_HOST)/bin/ldconfig:
+       touch $@
+       chmod +x $@
+
 $(eval $(call PrepareCommand,md5sum,gmd5sum md5sum $(SCRIPT_DIR)/md5sum))
 $(eval $(call PrepareCommand,cp,gcp cp))
 $(eval $(call PrepareCommand,seq,gseq seq))
@@ -143,7 +147,7 @@ $(eval $(call PrepareCommand,grep,ggrep grep))
 $(eval $(call PrepareCommand,tar,gtar tar))
 $(eval $(call PrepareCommand,diff,gdiff diff))
 
-$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,md5sum cp stat seq python awk getopt grep tar diff)
+$(curdir)/cmddeps = $(patsubst %,$(STAGING_DIR_HOST)/bin/%,md5sum cp stat seq python awk getopt grep tar diff ldconfig)
 $(curdir)//prepare = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)
 $(curdir)//compile = $(STAGING_DIR)/.prepared $(STAGING_DIR_HOST)/.prepared $($(curdir)/cmddeps)