fix gptu clocks
authorJohn Crispin <john@openwrt.org>
Wed, 19 Dec 2012 15:17:31 +0000 (15:17 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 19 Dec 2012 15:17:31 +0000 (15:17 +0000)
SVN-Revision: 34789

target/linux/lantiq/patches-3.7/0301-gptu.patch

index 4539d4a338c5ed664c14a358da1f2e1515344b61..33fb0fb86c1088fbd51dff0653ac99465a885fc5 100644 (file)
@@ -1,7 +1,7 @@
 Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
 ===================================================================
 --- /dev/null  1970-01-01 00:00:00.000000000 +0000
-+++ linux-3.7.1/arch/mips/lantiq/xway/timer.c  2012-12-18 20:47:56.625037132 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/timer.c  2012-12-18 22:24:36.133175326 +0100
 @@ -0,0 +1,841 @@
 +#include <linux/kernel.h>
 +#include <linux/module.h>
@@ -216,7 +216,7 @@ Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
 +
 +static inline void lq_enable_gptu(void)
 +{
-+      struct clk *clk = clk_get_sys("ltq_gptu", NULL);
++      struct clk *clk = clk_get_sys("1e100a00.gptu", NULL);
 +      clk_enable(clk);
 +
 +      //ltq_pmu_enable(PMU_GPT);
@@ -234,7 +234,7 @@ Index: linux-3.7.1/arch/mips/lantiq/xway/timer.c
 +
 +static inline void lq_disable_gptu(void)
 +{
-+      struct clk *clk = clk_get_sys("ltq_gptu", NULL);
++      struct clk *clk = clk_get_sys("1e100a00.gptu", NULL);
 +      ltq_w32(0x00, LQ_GPTU_IRNEN);
 +      ltq_w32(0xfff, LQ_GPTU_IRNCR);
 +
@@ -1007,7 +1007,7 @@ Index: linux-3.7.1/arch/mips/include/asm/mach-lantiq/lantiq_timer.h
 Index: linux-3.7.1/arch/mips/lantiq/xway/Makefile
 ===================================================================
 --- linux-3.7.1.orig/arch/mips/lantiq/xway/Makefile    2012-12-18 20:48:40.717038183 +0100
-+++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2012-12-18 20:49:10.129038884 +0100
++++ linux-3.7.1/arch/mips/lantiq/xway/Makefile 2012-12-18 22:24:48.965175632 +0100
 @@ -1,3 +1,3 @@
 -obj-y := prom.o sysctrl.o clk.o reset.o dma.o gptu.o dcdc.o
 +obj-y := prom.o sysctrl.o clk.o reset.o dma.o timer.o dcdc.o