mac80211: disable ipw2x00 for big endian targets
authorJonas Gorski <jogo@openwrt.org>
Sun, 23 Aug 2015 09:36:03 +0000 (09:36 +0000)
committerJonas Gorski <jogo@openwrt.org>
Sun, 23 Aug 2015 09:36:03 +0000 (09:36 +0000)
The ipw2x00 drivers assume that the system they are running is little
endian, and access everything in native byte order. When run on a big
endian system, everything breaks apart.

Since fixing this is non trivial on a first glance, disable them for
big endian targets.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46708

package/kernel/mac80211/Makefile

index 6afef107cb3244e09c690e13754604f980570a38..04dfd3b4ea43bb744834252e9e85bd247a2d9d2b 100644 (file)
@@ -719,7 +719,7 @@ endef
 define KernelPackage/net-libipw
   $(call KernelPackage/mac80211/Default)
   TITLE:=libipw for ipw2100 and ipw2200
-  DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT
+  DEPENDS:=@PCI_SUPPORT +kmod-crypto-core +kmod-crypto-arc4 +kmod-crypto-michael-mic +kmod-lib80211 +kmod-cfg80211 +@DRIVER_WEXT_SUPPORT @!BIG_ENDIAN
   FILES:=$(PKG_BUILD_DIR)/drivers/net/wireless/ipw2x00/libipw.ko
   AUTOLOAD:=$(call AutoProbe,libipw)
 endef